POJ 2115 C Looooops(exgcd—解一元线性同余方程)

C Looooops
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 23820 Accepted: 6591

Description

A Compiler Mystery: We are given a C-language style for loop of type 
for (variable = A; variable != B; variable += C)

  statement;

I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2k) modulo 2k

Input

The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2k) are the parameters of the loop. 

The input is finished by a line containing four zeros. 

Output

The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate. 

Sample Input

3 3 2 16
3 7 2 16
7 3 2 16
3 4 2 16
0 0 0 0

Sample Output

0
2
32766
FOREVER


题意:对于C的for(i=A ; i!=B ;i +=C)循环语句,问在k位存储系统中循环几次才会结束。若在有限次内结束,则输出循环次数。 否则输出死循环FOREVER。


题解:我们得到同余方程为 C*x≡(B-A)mod(2^k)。 将a=C,  b=B-A,  m=2^k 得到同余方程 ax ≡ b mod(m) 。剩下的就是解出这个同余方程的最小整数解了。


代码如下:


#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define LL long long

void exgcd(LL a,LL b,LL &d,LL &x,LL &y)
{
	if(!b)
	{
		x=1; y=0;
		d=a;
	}
	else
	{
		exgcd(b,a%b,d,y,x);
		y-=(a/b)*x;
	}
}

int main()
{
	LL A,B,C,k;
	while(scanf("%lld%lld%lld%lld",&A,&B,&C,&k))
	{
		if(A==0&&B==0&&C==0&&k==0)
			break;
		LL a=C,b=B-A,m=(LL)1<<k,x,y,d;
		exgcd(a,m,d,x,y);
		if(b%d)
			printf("FOREVER\n");
		else
		{
			x=(x*(b/d)%(m/d)+(m/d))%(m/d);
			printf("%lld\n",x);
		}
	}	
	return 0;
} 



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值