搜索 第一题 二分问题


Can you solve this equation?

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 149   Accepted Submission(s) : 47
Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;<br>Now please try your lucky.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 

Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 

Sample Input
  
  
2<br>100<br>-4<br>
 

Sample Output
  
  
1.6152<br>No solution!<br>
 

Author
Redow
 

题目大意

0-100 二分法

找值

很简单的啦~

j同感

一直wrong

#include<iostream>
#include<string.h>
#include<set>
#include<stdio.h>
#include<vector>
#include<algorithm>
#include<numeric>
#include<math.h>
#include<string.h>
#include<sstream>
#include<stdio.h>
#include<string>
#include<cstdlib>
#include<algorithm>
#include<iostream>
#include<map>
#include<queue>
#include<string>
#include<iomanip>
using namespace std;
double pao(double x)
{
    return 8*x*x*x*x+7*x*x*x+2*x*x+3*x+6;
}
int main()
{ int n;
  cin>>n;
  int i;
  double paopao;
  for(i=1;i<=n;i++)
  {
      cin>>paopao;
      if(paopao<6||paopao>pao(100))
      {
          cout<<"No solution!"<<endl;
      }
      else
      {
      double t=0;
      double max=100;
      double mid;
      while(1)
      {    double hh;
       hh=(max+t)/2;
          mid=pao(hh);
          if(mid>paopao)
          {
              max=hh;
          }
          if(mid<=paopao)
          {
              t=hh;
          }
          if((max-t)<=0.000000001)
          {  double ss;
              ss=(max+t)/2;
              cout<<fixed<<setprecision(4)<<ss<<endl;
              break;
          }
      }
      }

  }
return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值