猴子 堆箱子

Problem E

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 20   Accepted Submission(s) : 10
Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.<br><br>The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. <br><br>They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. <br><br>Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.<br>
 

Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,<br>representing the number of different blocks in the following data set. The maximum value for n is 30.<br>Each of the next n lines contains three integers representing the values xi, yi and zi.<br>Input is terminated by a value of zero (0) for n.<br>
 

Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".<br>
 

Sample Input
  
  
1 10 20 30 2 6 8 10 5 5 5 7 1 1 1 2 2 2 3 3 3 4 4 4 5 5 5 6 6 6 7 7 7 5 31 41 59 26 53 58 97 93 23 84 62 64 33 83 27 0
 

Sample Output
  
  
Case 1: maximum height = 40 Case 2: maximum height = 21 Case 3: maximum height = 28

Case 4: maximum height = 342

题目大意 这个猴子 需要吃香蕉 需要堆箱子 每个箱子 都要比小面那个 长宽小 求最大高度

dp思路

每个箱子 bool函数按照长度排序然后宽度 。

然后 分为3种情况 插入

一开始想插入箱子进行 排序的时候 重复使用但是 只能用一个类型只能用一次

举个例子

思考了好久 。。。。

举个例子 9 1 8

5 2 6

915 插入的时候有 9 1 5

5 1 9

9 5 1

8 2 6 插入的时候有 8 2 6

6 2 8

6 8 2

这样 排序的时候 就会有 5 6 6 8 9 9

1 2 2 2 1 1 1代表第一组 2代表第二组

当 到 9 时

按照 大小排序 真是好巧 9是最大值 所以 第二个值 肯定小 在前面 如果那个值备选了 后面肯定比他大 真的是好巧

ac代码~

#include<iostream>
#include<string.h>
#include<set>
#include<stdio.h>
#include<vector>
#include<algorithm>
#include<numeric>
#include<math.h>
#include<string.h>
#include<sstream>
#include<stdio.h>
#include<string>
#include<cstdlib>
#include<algorithm>
#include<iostream>
#include<map>
#include<queue>
#include<iomanip>
#include<cstdio>
using namespace std;
struct paopao
{
    int x,y,z;
}
;
paopao pao[10000];
bool cmp( paopao &A, paopao &B)
{
    if(A.x>B.x)
    return true;
    else if( A.x==B.x&&A.y>B.y)
       return true;
       else
       return false;
}
int dp[1005];
int main()
{
    int n;
    while(cin>>n&&n!=0)
    {    memset(dp,0,sizeof(dp));
        int p=1;
        int a,b,c;
        int i;
        int k=1;
        for(i=1;i<=n;i++)
        {
         cin>>a>>b>>c;
         pao[p].z=a;
         pao[p].x=max(b,c);
         pao[p].y=min(b,c);
         p++;
         pao[p].z=b;
         pao[p].x=max(a,c);
         pao[p].y=min(a,c);
         p++;
         pao[p].z=c;
         pao[p].x=max(a,b);
         pao[p].y=min(a,b);
         p++;
        }
        sort(pao+1,pao+p,cmp);
        for(i=1;i<=p-1;i++)
        {
            dp[i]=pao[i].z;
        }
        int j;
        int maxx=0;
        for(i=2;i<=p-1;i++)
        {
            maxx=0;
            for(j=1;j<i;j++)
            {
                if(pao[i].x>pao[j].x&&pao[i].y>pao[j].y&&dp[j]>maxx) //前三个肯定不满足 dp【j】好巧
                {
                    maxx=dp[j];
                }
            }
            dp[i]=maxx+pao[i].z;
        }
        maxx=-1;
        for(i=1;i<=p-1;i++)
        {
            if(dp[i]>maxx) maxx=dp[i];
        }
        cout<<"Case "<<k++<<": maximum height = ";
        cout<<maxx<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值