最小生成树Freckles

10 篇文章 0 订阅
5 篇文章 0 订阅
Freckles
Time Limit: 1000 ms Case Time Limit: 1000 ms Memory Limit: 64 MB
Total Submission: 167 Submission Accepted: 62
Description
In an episode of the Dick Van Dyke show, little Richie connects the freckles on his Dad's back to form a picture of the Liberty Bell. Alas, one of the freckles turns out to be a scar, so his Ripley's engagement falls through.
Consider Dick's back to be a plane with freckles at various (x,y) locations. Your job is to tell Richie how to connect the dots so as to minimize the amount of ink used. Richie connects the dots by drawing straight lines between pairs, possibly lifting the pen between lines. When Richie is done there must be a sequence of connected lines from any freckle to any other freckle.



Input
The first line contains 0 < n <= 100, the number of freckles on Dick's back. For each freckle, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the freckle.


Output
Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the freckles.


Sample Input
Original Transformed

3
1.0 1.0
2.0 2.0
2.0 4.0

Sample Output
Original Transformed

3.41

题意:给出一系列点,用最短的线将它们连接起来。

分析:单纯的最小生成树,只要在合并时累加距离即可。

#include<cstdio>
#include<algorithm>
#include<cmath>
using namespace std;

const int maxn = 110;

int father[maxn];

struct Point{
    double x, y;
}point[maxn];

struct Line{
    int p1, p2;
    double len;
    bool operator < (const Line& a) const {//重载操作符
        return len < a.len;
    }
}line[maxn*maxn];

double dist(Point a, Point b){
    return sqrt((a.x - b.x)*(a.x - b.x) + (a.y - b.y)*(a.y - b.y));
}

int findfather(int a){//查找
    if(a != father[a])
        father[a] = findfather(father[a]);
    return father[a];
}

bool Union(int a, int b){//合并
    int a_root, b_root;
    a_root = findfather(a);
    b_root = findfather(b);
    if(a_root == b_root)
        return false;
    father[b_root] = a_root;
    return true;
}

int main(){
    int n;
    while(~scanf("%d", &n)){
        double sum = 0.0;
        int k = 0;
        for(int i = 0; i < n; i++)
            scanf("%lf%lf", &point[i].x, &point[i].y);
        for(int i = 0; i < n; i++)//初始化数组
            father[i] = i;
        for(int i = 0; i < n; i++){
            for(int j = i + 1; j < n; j++){
                line[k].p1 = i;
                line[k].p2 = j;
                line[k++].len = dist(point[i], point[j]);
            }
        }
        sort(line, line + k);//贪心思想,排序
        for(int i = 0; i < k; i++)
            if(Union(line[i].p1, line[i].p2))//合并成功,累加距离
                sum += line[i].len;
        printf("%.2lf\n", sum);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值