HDOJ 1003

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 54335    Accepted Submission(s): 12213


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6
 



import java.util.Scanner;

public class Main {

	public static void main(String[] args) {

		int b[] = new int[3];

		Scanner scan = new Scanner(System.in);
		int n = scan.nextInt();
		for (int i = 1; i <= n; i++) {
			int m = scan.nextInt();
			int a[] = new int[m + 1];
			for (int j = 1; j <= m; j++) {
				a[j] = scan.nextInt();
			}
			int sum = new Main().maxSum(a, m, b);
			System.out.println("Case " + i + ":");
			System.out.println(sum + " " + b[1] + " " + b[2]);
			if (i != n)
				System.out.println();

		}
	}

	public int maxSum(int[] a, int n, int[] b) {
		int m = 0;
		int sum =-1001;
		int l = 1, r = 1;
		for (int i = 1; i <= n; i++) {
			if (m >= 0) {
				m += a[i];
				r = i;

			} else {
				m = a[i];
				l = i;
				r = i;
			}

			if (m > sum) {
				sum = m;
				b[1] = l;
				b[2] = r;

			}
		}
		return sum;
	}

}

开始测试数据没错,但总是WA,真是WA到吐血啊。。后来发现时sum初始化的错,题意说的是-1000~1000,我sum直接初始化为0了,后来才发现,粗心害死人啊!!!!
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值