【PAT B1019/A1069】 The Black Hole of Numbers

26 篇文章 1 订阅
16 篇文章 0 订阅

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 – the black hole of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we’ll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
… …
Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:
Each input file contains one test case which gives a positive integer N in the range (0,10^4​).

Output Specification:
If all the 4 digits of N are the same, print in one line the equation N - N = 0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

6767

Sample Output 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:

2222

Sample Output 2:

2222 - 2222 = 0000

思路:参考《算法笔记》。通过改变sort函数的cmp实现升序和降序两种排序方式,再相减得到结果。注意通过两个函数实现数字转换到数组、数组转换到数字的过程。

#include <cstdio>
#include <algorithm>

using namespace std;

bool cmp(int a, int b) {
    return a > b;
}

void to_array(int N, int num[]) {//将数字转换为数组
    for (int i = 0; i < 4; i++) {
        num[i] = N % 10;
        N /= 10;
    }
}

int to_num(const int num[]) {//将数组转换为数字
    int ans = 0;
    for (int i = 0; i < 4; i++) {
        ans = ans * 10 + num[i];
    }
    return ans;
}

int main() {
    int N, min, max;
    scanf("%d", &N);
    int num[4];
    while (1) {
        to_array(N, num);//将N转换为num数组
        sort(num, num + 4);//从小到大
        min = to_num(num);//将升序排列的数组转换为数字
        sort(num, num + 4, cmp);//从大到小
        max = to_num(num);//将降序排列的数组转换为数字
        N = max - min;
        printf("%04d - %04d = %04d\n", max, min, N);
        if (N == 0 || N == 6174) {//满足条件则跳出循环
            break;
        }
    }
    return 0;
}

思路二:利用stoi和to_string函数来实现字符串到数字和数字到字符串的转换过程。

#include <iostream>
#include <algorithm>

using namespace std;

bool cmp(char a, char b) { return a > b; }

int main() {
    string s;
    cin >> s;
    s.insert(0, 4 - s.length(), '0');//补0
    do {//如果当输入N值为6174的时候,依旧要进行下面的步骤
        string a = s, b = s;
        sort(a.begin(), a.end(), cmp);
        sort(b.begin(), b.end());
        int result = stoi(a) - stoi(b);
        s = to_string(result);
        s.insert(0, 4 - s.length(), '0');//补0
        cout << a << " - " << b << " = " << s << endl;
    } while (s != "6174" && s != "0000");
    return 0;
}

参考链接:link

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值