1012 The Best Rank (25 分)

1012 The Best Rank (25 分)

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of CME and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of CM and E. Then there are M lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A

======================================

模拟题。

1.

结构体存学生信息,结构体包括了ID,4个成绩,4个排名,4个排名中最好的排名。

struct node{
    int id, best;
    int score[4], rank[4];    //score依次是A, C, M, E的成绩
} stu[2005];

 

2.

接下来按类排序排名。依次按照A、C、M、E的成绩从大到小排名。

精髓是 flag 来控制。

flag = 0时,cmp函数中,a.score[flag] > b.score[flag];即按照A的成绩从大到小排序。

拍完名后计算A类排名,即stu[i].rank[0] = 多少; rank[0]是A类排名,rank[1]是C类排名...其他同理。

flag = 1,flag = 2,flag = 3;即按照C, M, E的成绩排名,排完之后也要计算每一类排名。

上述过程代码:

bool cmp(node a, node b){
    return a.score[flag] > b.score[flag];    //按照flag的值分类排序。
}

for(flag = 0; flag <= 3; flag++){
        sort(stu, stu + n, cmp);
        stu[0].rank[flag] = 1;    //按类排序后,计算按此类的排名。
        for(int i = 1; i < n; i++){
            stu[i].rank[flag] = i + 1;
            if(stu[i].score[flag] == stu[i-1].score[flag])
                stu[i].rank[flag] = stu[i-1].rank[flag];
        }
    }

3.计算每个同学的最好排名。这一步不用解释。

唯一需要注意的是:exist[t] = i + 1;//t是输入的学生 id。

exist[t] 是 t 的同学的序号 + 1。为什么加1,因为 i 从 0开始,如果不+1,则第一位同学 = 0,容易混淆。

4.输出。

char c[] = {'A', 'C', 'M', 'E'};
    for(int i = 0; i < m; i++){
        scanf("%d", &t);
        int temp = exist[t];    //获得这位同学的序号(需要-1才能真正的序号)
        if(temp){
            int best = stu[temp-1].best;
            printf("%d %c\n", stu[temp - 1].rank[best], c[best]);
        } else
            printf("N/A\n");
    }

======================================

#include <iostream>
#include <algorithm>
using namespace std;
struct node{
	int id, best;
	int score[4], rank[4];
} stu[2005];
int exist[1000000], flag;
bool cmp(node a, node b){
	return a.score[flag] > b.score[flag];
}
int main(){
	int n, m, t;
	cin >> n >> m;
	for(int i = 0; i < n; i++){
		scanf("%d %d %d %d", &stu[i].id, &stu[i].score[1], &stu[i].score[2], &stu[i].score[3]);
		stu[i].score[0] = (stu[i].score[1] + stu[i].score[2] + stu[i].score[3]) / 3.0 + 0.5;
	}
	for(flag = 0; flag <= 3; flag++){
		sort(stu, stu + n, cmp);
		stu[0].rank[flag] = 1;
		for(int i = 1; i < n; i++){
			stu[i].rank[flag] = i + 1;
			if(stu[i].score[flag] == stu[i-1].score[flag])
				stu[i].rank[flag] = stu[i-1].rank[flag];
		}
	}
	for(int i = 0; i < n; i++){
		exist[stu[i].id] = i + 1;
		stu[i].best = 0;
		int min = stu[i].rank[0];
		for(int j = 1; j <= 3; j++){
			if(stu[i].rank[j] < min){
				min = stu[i].rank[j];
				stu[i].best = j;
			}
		}
	}
	char c[] = {'A', 'C', 'M', 'E'};
	for(int i = 0; i < m; i++){
		scanf("%d", &t);
		int temp = exist[t];
		if(temp){
			int best = stu[temp-1].best;
			printf("%d %c\n", stu[temp - 1].rank[best], c[best]);
		} else
			printf("N/A\n");
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值