1019 General Palindromic Number (20 分)
A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.
Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b≥2, where it is written in standard notation with k+1 digits ai as ∑i=0k(aibi). Here, as usual, 0≤ai<b for all i and ak is non-zero. Then N is palindromic if and only if ai=ak−i for all i. Zero is written 0 in any base and is also palindromic by definition.
Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.
Input Specification:
Each input file contains one test case. Each case consists of two positive numbers N and b, where 0<N≤109 is the decimal number and 2≤b≤109 is the base. The numbers are separated by a space.
Output Specification:
For each test case, first print in one line
Yes
if N is a palindromic number in base b, orNo
if not. Then in the next line, print N as the number in base b in the form "ak ak−1 ... a0". Notice that there must be no extra space at the end of output.Sample Input 1:
27 2
Sample Output 1:
Yes 1 1 0 1 1
Sample Input 2:
121 5
Sample Output 2:
No 4 4 1
=================================
进制转换。
用vector<int> s;把除基取余的值保存下来。值赋给vector<int> t;
reverse()方法反转 s。 // s 即 除基取余倒排,是数字N的 b 进制。
判断 s 和 t 是否相等,相等是回文输出Yes,否则输出No。最后输出 s 中的值。
题目输入的N > 0,故不需要特判0。
=================================
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
int main(){
long long n, d;
cin >> n >> d;
vector<int> s, t;
while(n){
s.push_back(n % d);
n /= d;
}
t = s;
reverse(s.begin(), s.end());
printf("%s\n", t == s ? "Yes" : "No");
for(int i = 0; i < s.size(); i++){
if(i != 0) printf(" ");
printf("%d", s[i]);
}
return 0;
}
=====================================
题是通过了,但是我有个疑问,
如果博主这样写,样例4就会通不过,样例4不是0,而是一个很大的数。
博主怎么知道?while(n > 100000000) ; 空循环,如果n大于10 ^ 8就一直执行 空语句,样例4超时而不是答案错误,即可知道。
这段代码区别是没用vector<int>,直接用 字符串 存的,存数字时 + '0',输出时 -'0',其他都没变。
逻辑上没问题,部分正确18分,样例4通不过,为什么呢?如果你知道,欢迎评论指出。?
#include <iostream>
#include <algorithm>
using namespace std;
int main(){
long long n, d;
cin >> n >> d;
string s, t;
while(n){
s.push_back(n % d + '0');
n /= d;
}
t = s;
reverse(s.begin(), s.end());
printf("%s\n", t == s ? "Yes" : "No");
for(int i = 0; i < s.size(); i++){
if(i != 0) printf(" ");
printf("%d", s[i] - '0');
}
return 0;
}
============================