poj 1597 Uniform Generator

Uniform Generator
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 5035 Accepted: 2376

Description

Computer simulations often require random numbers. One way to generate pseudo-random numbers is via a function of the form
     seed(x+1) = [ seed(x) + STEP ] % MOD



     where "%" is the modulus operator.

Such a function will generate pseudo-random numbers (seed) between 0 and MOD-1. One problem with functions of this form is that they will always generate the same pattern over and over. In order to minimize this effect, selecting the STEP and MOD values carefully can result in a uniform distribution of all values between (and including) 0 and MOD-1.

For example, if STEP=3 and MOD=5, the function will generate the series of pseudo-random numbers 0, 3, 1, 4, 2 in a repeating cycle. In this example, all of the numbers between and including 0 and MOD-1 will be generated every MOD iterations of the function. Note that by the nature of the function to generate the same seed(x+1) every time seed(x) occurs means that if a function will generate all the numbers between 0 and MOD-1, it will generate pseudo-random numbers uniformly with every MOD iterations.

If STEP = 15 and MOD = 20, the function generates the series 0, 15, 10, 5 (or any other repeating series if the initial seed is other than 0). This is a poor selection of STEP and MOD because no initial seed will generate all of the numbers from 0 and MOD-1.

Your program will determine if choices of STEP and MOD will generate a uniform distribution of pseudo-random numbers.

Input

Each line of input will contain a pair of integers for STEP and MOD in that order (1<=STEP,MOD<=100000).

Output

For each line of input, your program should print the STEP value right-justified in columns 1 through 10, the MOD value right-justified in columns 11 through 20 and either "Good Choice" or "Bad Choice" left-justified starting in column 25. The "Good Choice" message should be printed when the selection of STEP and MOD will generate all the numbers between and including 0 and MOD-1 when MOD numbers are generated. Otherwise, your program should print the message "Bad Choice". After each output test set, your program should print exactly one blank line.

Sample Input

3 5
15 20
63923 99999

Sample Output

         3         5    Good Choice

        15        20    Bad Choice

     63923     99999    Good Choice
题解:  来自:http://www.cppblog.com/pcfeng502/archive/2009/10/21/99138.html

题目的意思就是一个生成随机数的函数,

     Seed[x+1] = ( seed[x] + STEP ) % MOD

其中seed就是我们生成出来的随机数,至于seed[0]是哪个数并不重要,后面会证明。STEP就是我们每次往前一个所加的值,再module上MOD得到下一个随机数。

 

判断这个随机生成函数的好坏的依据是如果能够产生0~MOD-1内的所有数,就是一个好的,否则坏。

 

我们知道了同余的特性,便可以假设在k步之后,生成的seed[k] = seed[0],所以由此有

        Seed[k] = ( seed[0] + STEP*k ) % MOD

那么,

        STEP * k = MOD

 

而我们如果要生产MOD个数,必须使kMOD,而且k不可能大于MOD,因为这个条件下生成的数又开始重复,所以k=MOD在前面的条件下,如果STEP和MOD有大于1的公约数例如d,那么会有STEP*(k/d) = MOD,这就是一个循环了,只会产生k/d<MOD个随机数。

结论:iff gcd(STEP, MOD) == 1, good choice.

AC code:
#include <stdio.h>


long fun(long a,long b)
{
    if(a<b){
        int temp=a;
        a=b;
        b=temp;
    }
    while(b)
    {
        int t=a;
        a=b;
        b=t%b;
    }
    return a;
}
int main()
{
    long  STEP,MOD,t;
    while(scanf("%d%d",&STEP,&MOD)!=EOF)
    {
            t=fun(STEP,MOD);
        if(t==1)
            printf("%10d%10d    Good Choice\n\n",STEP,MOD);
        else
            printf("%10d%10d    Bad Choice\n\n",STEP,MOD);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值