sgu144

10 篇文章 0 订阅

题目:

144. Meeting

time limit per test: 0.25 sec. 
memory limit per test: 4096 KB

Two of the three members of the winning team of one of the ACM regional contests are going to meet in order to train for the upcoming World Finals. They decided that they will meet sometime between X o'clock and Y o'clock. Because they never get anywhere on time (they were late even on the day of the regional contest), they did not set an exact time when they will meet. However, they decided that the one who gets first at the meeting point will not wait more than Z minutes for the other one (they calculated that, if the other one will not come within Z minutes from the arrival of the first of them, then it is very probable that he will not show up at all). 
Knowing that, in the end, both of them will show up at some time between X o'clock and Y o'clock (not necessarily after an integer number of minutes), compute which is the probability that they will actually meet.

Input

The input will contain 2 integer numbers X and Y (0<=X<Y<=24) and one real number Z ( 0 < Z <= 60*(Y-X) ).

Output

You should output the required probability with 7 decimal digits (rounded according to the 8th decimal digit).

Sample Input

11 12 20.0

Sample Output

0.5555556

题解:


答案为S1面积与总面积之比


代码:

#include <cstdio>
int main()
{
<span style="white-space:pre">	</span>double time1, time2, wait, s, bc, s1;
<span style="white-space:pre">	</span>while (scanf("%lf%lf%lf", &time1, &time2, &wait) != EOF)
<span style="white-space:pre">	</span>{
<span style="white-space:pre">		</span>bc = (time2 - time1) * 60;
<span style="white-space:pre">		</span>s = bc * bc;
<span style="white-space:pre">		</span>s1 = s - (bc - wait) * (bc - wait);
<span style="white-space:pre">		</span>printf("%.7f\n", s1 / s);
<span style="white-space:pre">	</span>}
<span style="white-space:pre">	</span>return 0;
}

代码丑陋不要见怪

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值