Time Limit: 1000 MS Memory Limit: 131072 K
Description
In this problem you are to calculate the sum of all integers from 1 to n, but you should take all powers of two with minus in the sum.
For example, for n=4 the sum is equal to -1-2+3-4=-4, because 1, 2 and 4 are 2^0, 2^1 and 2^2 respectively.
Calculate the answer for t values of n.
Input
The first line of the input contains a single integer t (1≤t≤100) — the number of values of n to be processed.
Each of next t lines contains a single integer n (1≤n≤10^9).
Output
Print the requested sum for each of t integers n given in the input.
Sample Input
2
4
1000000000
Sample Output
-4
499999998352516354
题意:从1到n相加的和,但是遇到2^0,2^1,2^2,,,等等,要把这个数变成负数。
脑残数学毁一生,zz,就是一个数学题;
一个等差数列减去两个等比数列
等差数列指,从1加到n;
等比数列指,2^0,2^1,2^2,,,等等
#include<cstdio>
#include <cstring>
#include<cmath>
#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
int main ()
{
long long sum,n,t;
int i;
scanf("%lld",&t);
while(t--)
{
scanf("%lld",&n);
for(i=0;pow(2,i)<=n;i++);
printf("%lld\n",n*(n+1)/2-2*((1<<i)-1));
}
return 0;
}