POJ 2352 stars

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

  

     题目大致题意:给你n颗星星的坐标,然后有0到n-1个等级,问你每个等级有多少个星星?等级的定义是:当前星星的左下(包括左,下)有多少个星星,该星星就属于第几个等级!

     感想:这道题真的的是太简单咯,就是理解题意有点难,很久才明白!

    思路:题意给的星星的坐标是按照y升序录入,如果y相同,按照x升序,因此,直接使用x就行咯,但是要注意的是:树状数组的下标不能为0,所以x+1;

   AC代码:

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<iostream>
using namespace std;
const int maxn=150008;
int c[maxn],n,MAX;
int cnt[maxn];
int lowbit(int x)
{
    return x&(-x);
}
int sum(int x)
{
    int ans=0;
    while(x)
    {
        ans+=c[x];
        x-=lowbit(x);
    }
    return ans;
}
void add(int x,int idx)
{
    while(x<=maxn)
    {
        c[x]+=idx;
        x+=lowbit(x);
    }
}
int main()
{
    while(cin>>n)
    {
        for(int i=1; i<=n; i++)
        {
            int x,y;
            cin>>x>>y;
            cnt[sum(x+1)]++;//统计每个级别的星星数量;
            add(x+1,1);
        }
        for(int i=0; i<n; i++)
            printf("%d\n",cnt[i]);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值