Advanced Level 1001 A+B Format (20 point(s))

PAT甲级系列👉PAT_Advanced_Level

英文

Title

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification::

Each input file contains one test case. Each case contains a pair of integers a and b where − 1 0 6 ⩽ a , b ⩽ 1 0 6 -10^6\leqslant a,b\leqslant 10^6 106a,b106​​ . The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

中文

题目

计算 a+b 并以标准格式输出总和----也就是说,从最低位开始每隔三位数加进一个逗号(千位分隔符),如果结果少于四位则不需添加。

输入格式

共一行,包含两个整数 a 和 b。

输出格式

共一行,以标准格式输出 a+b 的和。

数据范围

− 1 0 6 ≤ a , b ≤ 1 0 6 −10^6≤a,b≤10^6 106a,b106

输入样例:

-1000000 9

输出样例

-999,991

思路分析:

利用函数to_string将A+B的值转换为字符串,然后将该字符串倒序遍历,变量j3等于0的时候,且当前i不是第0位,s[i-1]不等于-的时候,我们在答案变量res之前加入一个,

代码:

#include <iostream>
#include <algorithm>
#include <cstring>

using namespace std;

int main() {
    int a, b;
    cin >> a >> b;
    string s = to_string(a + b), res;
    for (int i = s.size() - 1, j = 1; i >= 0; -- i, ++ j) {
        res = s[i] + res;
        if (j % 3 == 0 && i && s[i - 1] != '-') res = ',' + res;
    }
    cout << res << endl;
    return 0;
}

注:如果您通过阅读本文解决了问题,恳请您留下一个宝贵的赞再离开,如果不嫌弃的话,点个关注再走吧,非常欢迎您能够在讨论区指出此文的不足处,博主会及时对文章加以修正 !如果有任何问题,欢迎评论,非常乐意为您解答!( •̀ ω •́ )✧

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值