poj 1201 Intervals

Description

You are given n closed, integer intervals [ai, bi] and n integers c1, ..., cn. 
Write a program that: 
reads the number of intervals, their end points and integers c1, ..., cn from the standard input, 
computes the minimal size of a set Z of integers which has at least ci common elements with interval [ai, bi], for each i=1,2,...,n, 
writes the answer to the standard output. 

Input

The first line of the input contains an integer n (1 <= n <= 50000) -- the number of intervals. The following n lines describe the intervals. The (i+1)-th line of the input contains three integers ai, bi and ci separated by single spaces and such that 0 <= ai <= bi <= 50000 and 1 <= ci <= bi - ai+1.

Output

The output contains exactly one integer equal to the minimal size of set Z sharing at least ci elements with interval [ai, bi], for each i=1,2,...,n.

Sample Input

5
3 7 3
8 10 3
6 8 1
1 3 1
10 11 1

Sample Output

6

差分约束模板题,本质是最短路径

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<queue>
using namespace std;
#define ll long long
const int maxn=50001;
const int INF=1<<30;
#define getMax(a,b) (a>b?a:b)
#define getMin(a,b) (a<b?a:b)
struct node{
    int v,w,next;
};
node edge[3*maxn];
int dist[maxn],head[maxn],vis[maxn];
int n,Max,Min,k;
void addedge(int u,int v,int w)
{
    edge[k].v=v;
    edge[k].w=w;
    edge[k].next=head[u];
    head[u]=k++;
}
void spfa()
{
    int i;
    for (i=Min;i<=Max;i++)
        dist[i]=-INF;
    dist[Min]=0;
    queue<int>q;
    q.push(Min);
    while (!q.empty())
    {
        int x=q.front();
        q.pop();
        vis[x]=0;
        for (int e=head[x];e!=-1;e=edge[e].next)
            if (dist[edge[e].v]<dist[x]+edge[e].w)
            {
                dist[edge[e].v]=dist[x]+edge[e].w;
                if (!vis[edge[e].v])
                {
                    q.push(edge[e].v);
                    vis[edge[e].v]=1;
                }
            }
    }
}
int main()
{
    while (~scanf("%d",&n))
    {
        int u,v,w;
        k=0;
        memset(head,-1,sizeof(head));
        memset(vis,0,sizeof(vis));
        memset(edge,0,sizeof(edge));
        Min=INF;
        Max=-INF;
        for (int i=0;i<n;i++)
        {
            scanf("%d%d%d",&u,&v,&w);
            addedge(u,v+1,w);
            Min=getMin(Min,u);
            Max=getMax(Max,v+1);
        }
        for (int i=Min;i<Max;i++)
        {
            addedge(i,i+1,0);
            addedge(i+1,i,-1);
        }
        spfa();
        printf("%d\n",dist[Max]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值