poj 1469 COURSES

Description

Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions: 

  • every student in the committee represents a different course (a student can represent a course if he/she visits that course) 
  • each course has a representative in the committee 

Input

Your program should read sets of data from the std input. The first line of the input contains the number of the data sets. Each data set is presented in the following format: 

P N 
Count1 Student 1 1 Student 1 2 ... Student 1 Count1 
Count2 Student 2 1 Student 2 2 ... Student 2 Count2 
... 
CountP Student P 1 Student P 2 ... Student P CountP 

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses �from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you抣l find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N. 
There are no blank lines between consecutive sets of data. Input data are correct. 

Output

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

Sample Input

2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1

Sample Output

YES
NO

先贴上代码:

#include<iostream>
#include<algorithm>
#include<string.h>
#include<stdio.h>
using namespace std;
#define M 101
#define N 301
int vis[N],link[N],match[M][N];
/*link数组里面存放的是匹配结果,match数组里面存放的
是它们之间的关系,vis数组代表的是访问记录*/
int p,n;
void init()
{
    memset(match,0,sizeof(match));
    memset(link,-1,sizeof(link));
}
int hungarian(int t)
{
    int i;
    for (i=1;i<=n;i++)
    {
        if (vis[i]==0&&match[t][i])
        {
           // printf("===%d %d %d===\n",t,i,link[i]);
            vis[i]=1;
            if (link[i]==-1||hungarian(link[i]))
            {
                link[i]=t;   //若link[i]等于-1或者经过调整以后可以找到没被匹配的,然后进行赋值成t,说明t与i匹配了。
                return 1;      
            }
        }
    }
    return 0;
}
int main()
{
    int i,j,t;
    scanf("%d",&t);
    while (t--)
    {
        init();
       scanf("%d%d",&p,&n);
       for (i=1;i<=p;i++)
       {
           int num,stu;
           scanf("%d",&num);
           for (j=1;j<=num;j++)
           {
               scanf("%d",&stu);
               match[i][stu]=1;
           }
       }
       int ans=0;
       for (i=1;i<=p;i++)
       {
           memset(vis,0,sizeof(vis));
           if (hungarian(i))
              ans++;
       }
       //printf("%d\n",ans);
        if (ans==p)
            printf("YES\n");
        else
            printf("NO\n");
    }

    return 0;
}

若改变执行的顺序,让i从p到1进行饥饿搜索与从1到p进行饥饿搜索时间就不一样,因为有可能执行的link[i]==-1,也有可能执行递归算法。

 

 




 



 

 



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值