USACO 2014 Dec Silver 1.Piggyback 题解

12 篇文章 0 订阅
8 篇文章 0 订阅

Description

Bessie and her sister Elsie graze in different fields during the day,
and in the evening they both want to walk back to the barn to rest.
Being clever bovines, they come up with a plan to minimize the total
amount of energy they both spend while walking.

Bessie spends B units of energy when walking from a field to an
adjacent field, and Elsie spends E units of energy when she walks to
an adjacent field.  However, if Bessie and Elsie are together in the
same field, Bessie can carry Elsie on her shoulders and both can move
to an adjacent field while spending only P units of energy (where P
might be considerably less than B+E, the amount Bessie and Elsie would
have spent individually walking to the adjacent field).  If P is very
small, the most energy-efficient solution may involve Bessie and Elsie
traveling to a common meeting field, then traveling together piggyback
for the rest of the journey to the barn.  Of course, if P is large, it
may still make the most sense for Bessie and Elsie to travel
separately.  On a side note, Bessie and Elsie are both unhappy with
the term "piggyback", as they don't see why the pigs on the farm
should deserve all the credit for this remarkable form of
transportation.

Given B, E, and P, as well as the layout of the farm, please compute
the minimum amount of energy required for Bessie and Elsie to reach
the barn.

Input

The first line of input contains the positive integers B, E, P, N, and
M.  All of these are at most 40,000.  B, E, and P are described above.
N is the number of fields in the farm (numbered 1..N, where N >= 3),
and M is the number of connections between fields.  Bessie and Elsie
start in fields 1 and 2, respectively.  The barn resides in field N.

The next M lines in the input each describe a connection between a
pair of different fields, specified by the integer indices of the two
fields.  Connections are bi-directional.  It is always possible to
travel from field 1 to field N, and field 2 to field N, along a series
of such connections.  

Output

A single integer specifying the minimum amount of energy Bessie and
Elsie collectively need to spend to reach the barn.  In the example
shown here, Bessie travels from 1 to 4 and Elsie travels from 2 to 3
to 4.  Then, they travel together from 4 to 7 to 8.

Sample Input

4 4 5 8 8
1 4
2 3
3 4
4 7
2 5
5 6
6 8
7 8

Sample Output

22
这道题是一个人从1出发,一个人从2出发.到达n点,中途可以合并.

三次最短路,1,2,n各一次找最小值

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int head[80001];
int idx,to[80001];
int next[80001];
int front,tail;
int f1[80001],f2[80001],f3[80001];
int queue[160001];
int ans=1e9;
int main()
{
	int a,b,c,n,m,i,x,y,j;
	scanf("%d%d%d%d%d",&a,&b,&c,&n,&m);
	for(i=1;i<=m;i++)
	{
		scanf("%d%d",&x,&y);
		next[++idx]=head[x];
		head[x]=idx;
		to[idx]=y;
		next[++idx]=head[y];
		head[y]=idx;
		to[idx]=x;		
	}
	memset(f1,1,sizeof(f1));
	memset(f2,1,sizeof(f2));
	memset(f3,1,sizeof(f3));
	f1[1]=0;
	front=tail=0;
	queue[tail++]=1;		
	while(front<=tail)
	{
		int idx1=queue[front++];
		for(j=head[idx1];j;j=next[j])
		{
			if(f1[to[j]]>f1[idx1]+a)
			{
				f1[to[j]]=f1[idx1]+a;
				queue[tail++]=to[j];				
			}
		}
	}
	memset(queue,0,sizeof(queue));
	f2[2]=0;
	front=tail=0;
	queue[tail++]=2;
	while(front<=tail)
	{
		int idx1=queue[front++];
		for(j=head[idx1];j;j=next[j])
		{
			if(f2[to[j]]>f2[idx1]+b)
			{
				f2[to[j]]=f2[idx1]+b;
				queue[tail++]=to[j];				
			}
		}
	}	
	memset(queue,0,sizeof(queue));
	f3[n]=0;
	front=tail=0;
	queue[tail++]=n;
	while(front<=tail)
	{
		int idx1=queue[front++];
		for(j=head[idx1];j;j=next[j])
		{
			if(f3[to[j]]>f3[idx1]+c)
			{
				f3[to[j]]=f3[idx1]+c;
				queue[tail++]=to[j];				
			}
		}
	}		
	for(i=1;i<=n;i++)
		ans=min(ans,(f1[i]+f2[i]+f3[i]));
	printf("%d",ans);
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值