[sgu 548] Dragons and Princesses

题目描述:

 Dragons and Princesses
Time limit per test: 2 second(s)
Memory limit: 262144 kilobytes
input: standard
output: standard



Once upon a time there lived the Knight. Being very courageous he decided to make a long journey full of fights and adventures. The map of this journey can be represented as a row with n cells numbered from 1 to n from left to right. Initially the Knight is located at the leftmost cell (cell number 1). He should pass all the cells one by one and finish his way at the rightmost cell (cell number n). He is not allowed to move back or skip some cells, he will visit all the cells from the first to the last.

Each cell except the first one contains either a dragon or a princess. Each dragon has a chest with gold coins. The dragon at the cell i keeps gi coins. Every time the Knight steps to a cell with a dragon he has a choice  — to kill the dragon or just to pass through. The Knight is very strong and dexterous, so it is not a problem for him to kill any dragon on his way. If a dragon is killed the Knight gets all the gold dragon possessed.

When the Knight steps to the cell with a princess, she wonders how many dragons he has killed. If that number is greater or equal to her beauty bi, the princess considers the Knight brave enough and instantly asks him to marry her. Being a true gentleman, the Knight cannot refuse and his adventure immediately ends.

The Knight loves the princess who lives in the cell number n and wants to marry her. Also during the journey he wants to collect as much gold as possible. Please help him to accomplish this task.

Input
The first line of the input contains a single integer n (2 ≤ n ≤ 2·105) — the number of cells. The next n-1 lines describe cells from 2 to n.

If the cell number i contains a dragon, the i-th line of the input contains letter "
d
" followed by a single integer gi (1 ≤ gi ≤ 104) — the number of coins the dragon keeps. The letter and the integer are separated by a single space.

If the cell number i contains a princess, the i-th line of the input contains letter "
p
" followed by a single integer bi (1 ≤ bi ≤ 2·105) — the beauty of the princess. The letter and the integer are separated by a single space. It is guaranteed that the last cell contains a princess.

Output
On the first line of the output print a single integer — the maximum number of gold coins the Knight can collect. On the second line print a single integer k — the number of dragons to kill. The third line should contain k integers — the numbers of the cells where the Knight should kill a dragon. The cell numbers should be printed in the increasing order.

If there are several optimal solutions, output any of them. If the Knight can't marry his beloved princess, just print
-1
in the first line of the output.

Example(s)
sample input
sample output
6
d 10
d 12
p 2
d 1
p 2
13
2
3 5

sample input
sample output
6
d 10
d 12
p 2
d 1
p 3
-1

这道题开始贪心的算法想错了T.T,后来听大神说了后发现还是比较简单的,可以用优先队列把龙存下来,再按照公主的顺序,如果龙的优先队列少于公主的要求则不做任何事,如果多于,则减少pi值少的直至符合少于,最后判断排序一下输出就行了,哦,对了,可以用结构体保存龙的pi值和序号。

#include<iostream>
#include<cstdio>
#include<queue>
#include<algorithm>
#include<cstring>

using namespace std;
struct d{
	friend bool operator< (d n1,d n2)
	{
		return n1.p>n2.p;
	}
	int p,x;
};
priority_queue<d> a;
queue<int> b;
int order[200001];

int main()
{
int n;
while(scanf("%d",&n)!=EOF)
 {
 	for (int i=1;i<n-1;i++)
 	 {
 	 	char p;
 	 	int c;
 	 	scanf(" %c%d",&p,&c);
 	 	if (p=='d')
 	 	 {
 	 	 	d e;
 	 	 	e.p=c;
 	 	 	e.x=i+1;
 	 	 	a.push(e);
 	 	 }
 	 	 else b.push(c);
 	 	 while(!b.empty())
 	 	{
 	 		int cnt=b.front();
 	 		int m=a.size();
 	 		for (int i=1;i<=m-cnt+1;i++)
 	 		 a.pop();
 	 		b.pop();
 	 	}
 	 	 }
 	 	char p;
 	 	int min;
 	 	scanf(" %c%d",&p,&min);
 	 	
 	 	int m=a.size();
 	 	int sum=0;
 	 	int cnt=0;
 	 	memset(order,0,sizeof order);
 	 	 for (int i=1;i<=m;i++)
 	 	  {
 	 	  	d e;
 	 	  	e=a.top();
 	 	  	sum+=e.p;
 	 	  	order[cnt++]=e.x;
 	 	  	a.pop();
 	 	  }
 	 	if (sum==0||m<min)
		   printf("-1\n");
		   else {
		   	printf("%d\n%d\n",sum,m);
		   	sort(order,order+m);
		   	printf("%d",order[0]);
		   	for (int i=1;i<m;i++)
		   	 printf(" %d",order[i]);
		   	printf("\n");
		   }  
 	 }
 	 return 0;
 	
 }	

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值