阿里云linux下 升级PHP版本
  • 1223

首先更新系统软件

$ yum update

在centos7通过yum安装PHP7,首先在终端运行:

rpm -Uvh https://mirror.webtatic.com/yum/el7/webtatic-release.rpm

如果提示错误:

error: Failed dependencies:

epel-release >= 7 is needed by webtatic-release-7-3.noarch

需要先安装epel-release。

1.安装epel-release

通过命令:

rpm -ivh http://dl.fedoraproject.org/pub/epel/7/x86_64/e/epel-release-7-5.noarch.rpm

成功安装。

2.安装PHP7

终端再次运行如下命令:

rpm -Uvh https://mirror.webtatic.com/yum/el7/webtatic-release.rpm

成功获取PHP7的yum源,然后再执行:

yum install php70w

这样就大功告成了。

3.验证安装

终端命令:php -v,显示当前PHP版本,信息如下:

阅读更多
文章标签: php
个人分类: php
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

不良信息举报

阿里云linux下 升级PHP版本

最多只允许输入30个字

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭