杭电1016--Prime Ring Problem(DF…

Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

杭电1016--Prime <wbr>Ring <wbr>Problem(DFS)
Input
n (0 < n < 20).
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
Sample Input
6 8
Sample Output
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 

# include<stdio.h>
# include<string.h>
int n,use[25],record[25],num,prim[50];
void DFS(int num)
{
       int i,j;
       if(num==n&&prim[record[num]+1])
       {
              printf("1");
              for(i=2;i<=n;i++)
                     printf(" %d",record[i]);
              printf("\n");
              return ;
       }
       for(j=2;j<=n;j++)
       {
              if(use[j]==0&&prim[j+record[num]]>0)
              {
                     use[j]=1;
                     record[num+1]=j;
                     DFS(num+1);
                     use[j]=0;
              }
       }
}
int main()
{
       int i,j,t;
       for(i=2;i<=50;i++)
              prim[i]=i;
       for(i=2;i<=7;i++)
          if(prim[i])
        for(j=i*2;j<=50;j+=i)
                     prim[j]=0;
       prim[1]=0;
       t=1;
       while(scanf("%d",&n)!=EOF)
       {
              memset(use,0,sizeof(use));
              use[1]=1;
              record[1]=1;
              printf("Case %d:\n",t++);
              DFS(1);
              printf("\n");
       }
       return 0;
}
 
 
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值