POJ-1502 MPI Maelstrom(Dijkstra❤)

首先了解一下什么是下三角:就是对角线之下的不包括对角线的部分。

题意:看半天题...给你半个矩阵,数字表示权值,x表示两点间不可达,由于自身到自身花费的时间为0,所以没有给出,由于i到j和j到i距离相同,互达时间相同,所以只给出了一半的临界矩阵。根据这个矩阵,让你来求从点1到其他点所花费最短时间集里面的的最大值。 

 题目

BIT has recently taken delivery of their new supercomputer, a 32 processor Apollo Odyssey distributed shared memory machine with a hierarchical communication subsystem. Valentine McKee's research advisor, Jack Swigert, has asked her to benchmark the new system.
``Since the Apollo is a distributed shared memory machine, memory access and communication times are not uniform,'' Valentine told Swigert. ``Communication is fast between processors that share the same memory subsystem, but it is slower between processors that are not on the same subsystem. Communication between the Apollo and machines in our lab is slower yet.''

``How is Apollo's port of the Message Passing Interface (MPI) working out?'' Swigert asked.

``Not so well,'' Valentine replied. ``To do a broadcast of a message from one processor to all the other n-1 processors, they just do a sequence of n-1 sends. That really serializes things and kills the performance.''

``Is there anything you can do to fix that?''

``Yes,'' smiled Valentine. ``There is. Once the first processor has sent the message to another, those two can then send messages to two other hosts at the same time. Then there will be four hosts that can send, and so on.''

``Ah, so you can do the broadcast as a binary tree!''

``Not really a binary tree -- there are some particular features of our network that we should exploit. The interface cards we have allow each processor to simultaneously send messages to any number of the other processors connected to it. However, the messages don't necessarily arrive at the destinations at the same time -- there is a communication cost involved. In general, we need to take into account the communication costs for each link in our network topologies and plan accordingly to minimize the total time required to do a broadcast.''

Input

The input will describe the topology of a network connecting n processors. The first line of the input will be n, the number of processors, such that 1 <= n <= 100.

The rest of the input defines an adjacency matrix, A. The adjacency matrix is square and of size n x n. Each of its entries will be either an integer or the character x. The value of A(i,j) indicates the expense of sending a message directly from node i to node j. A value of x for A(i,j) indicates that a message cannot be sent directly from node i to node j.

Note that for a node to send a message to itself does not require network communication, so A(i,i) = 0 for 1 <= i <= n. Also, you may assume that the network is undirected (messages can go in either direction with equal overhead), so that A(i,j) = A(j,i). Thus only the entries on the (strictly) lower triangular portion of A will be supplied.

The input to your program will be the lower triangular section of A. That is, the second line of input will contain one entry, A(2,1). The next line will contain two entries, A(3,1) and A(3,2), and so on.

Output

Your program should output the minimum communication time required to broadcast a message from the first processor to all the other processors.

Sample Input

5
50
30 5
100 20 50
10 x x 10

Sample Output

35

 AC代码<[GO!]

注意注意注意:这道题要用到atoi()函数

atoi:把字符串nptr转换为int。

atol:把字符串nptr转换为long int。

atol:把字符串nptr转换为long long int。

atoq:atoq() is an obsolete name for atoll()。

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<stdlib.h>
using namespace std;
int e[110][110],dis[110],book[110];
int main()
{
	char s[110];
	int i,j,n,m,t1,t2,t3,u,v,min;
	int inf=99999999;
	while(~scanf("%d",&n))
	{
		//初始化e数组
		for(i=1;i<=n;i++)
		{
			if(i==j)
				e[i][j]=0;
			else
				e[i][j]=inf;	
		} 
		//输入
		for(i=2;i<=n;i++)
		{
			for(j=1;j<i;j++)
			{
				scanf("%s",s);
				if(s[0]!='x')
				{
					e[i][j]=e[j][i]=atoi(s);
				}
				else
					e[i][j]=e[j][i]=inf;		
			}	
		} 
		//初始化dis数组
		for(i=1;i<=n;i++)
			dis[i]=e[1][i];
		//book数组初始化
		for(i=1;i<=n;i++)
			book[i]=0;
		book[1]=1;
		//dijkstra算法核心语句
		for(i=1;i<=n-1;i++)
		{
			min=inf;
			for(j=1;j<=n;j++)
			{
				if(book[j]==0&&dis[j]<min)
				{
					min=dis[j];
					u=j;	
				}	
			}	
			book[u]=1;
			for(v=1;v<=n;v++)
			{
				if(e[u][v]<inf)
				{
					if(dis[v]>dis[u]+e[u][v])
						dis[v]=dis[u]+e[u][v];	
				}
			}
		} 
		int ans=0;
		for(i=1;i<=n;i++)
		{
			if(dis[i]>ans)
				ans=dis[i];
		}
		printf("%d\n",ans);
	}
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值