HDU-1102 Constructing Roads Prime★★

本题是一道水题只是英语比较难理解,题目大意说的是有n个村子知道每个村子之间的距离,有的村子之间路以修过求剩下的路的距离最小值,比如题目中的这个数据 3意为有三个村子,0 990 692分别是第一个村子到第一个村子,到第二个村子,到第三个村子,各自的距离。第二行同理第二个村子分别到1 2 3的距离,第四行1说明有一条路已经修,第五行给出这两个村子的编号。🌞

题目 

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output

179

 AC代码🎃

#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
int e[110][110],dis[110],book[110];
int n;
int inf=99999999;
int main()
{
	int i,j,u,v,min,a,b,c,sum;
	while(~scanf("%d",&n))
	{
		sum=0;
		memset(e,0,sizeof(e));
		for(i=1;i<=n;i++)
		{
			for(j=1;j<=n;j++)
			{
				scanf("%d",&e[i][j]);
			}
		}
		scanf("%d",&a);
		for(i=1;i<=a;i++)
		{
			scanf("%d%d",&b,&c);
			e[b][c]=e[c][b]=0;
		}
		for(i=1;i<=n;i++)
		{
			book[i]=0;
			dis[i]=e[1][i];
		}
		book[1]=1;
//		dis[1]=0;
		for(i=1;i<n;i++)
		{
			min=inf;
			for(j=1;j<=n;j++)
			{
				if(book[j]==0&&dis[j]<min)
				{
					min=dis[j];
					u=j;
				}
			}
			book[u]=1;
			sum=sum+dis[u];
			for(v=1;v<=n;v++)
			{
				if(dis[v]>e[u][v]&&book[v]==0)
					dis[v]=e[u][v];
			}
		}
		printf("%d\n",sum);
	}
	return 0;
}

努力努力🎀

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值