The Balance (母函数)

The Balance

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 137 Accepted Submission(s): 90
 
Problem Description
Now you are asked to measure a dose of medicine with a balance and a number of weights. Certainly it is not always achievable. So you should find out the qualities which cannot be measured from the range [1,S]. S is the total quality of all the weights.
 
Input
The input consists of multiple test cases, and each case begins with a single positive integer N (1<=N<=100) on a line by itself indicating the number of weights you have. Followed by N integers Ai (1<=i<=N), indicating the quality of each weight where 1<=Ai<=100.
 
Output

            For each input set, you should first print a line specifying the number of qualities which cannot be measured. Then print another line which consists all the irrealizable qualities if the number is not zero.
 
Sample Input
3
1 2 4
3
9 2 1
 
Sample Output
0
2
4 5
 

题意,给你几个砝码,总和以内,什么质量称不出来。
首先要理解母函数的定义。
//freopen("/Users/zhangzhichao/Documents/HDOJ/HDOJ/1.txt", "r", stdin);
#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <string>
#include <vector>
#include <string.h>
#include <memory>
#include <queue>
using namespace std;
const int MAXN = 12000;
vector<int> ans;
int a[MAXN];
int c[MAXN];
int temp[MAXN];
int main() {
    int n;
    int sum;
    while (scanf("%d", &n) != EOF) {
        for (int i = 0; i <= MAXN; ++i)
            c[i] = 0;
        ans.clear();
        sum = 0;
        for (int i = 0; i < n; ++i) {
            scanf("%d", a + i);
        }
        sum = a[0];
        c[0] = c[sum] = 1;
        for (int i = 1; i < n; ++i) {
            for (int j = 0; j <= sum; ++j) {
                for (int k = 0; k <= a[i]; k += a[i]) {
                    temp[k + j] += c[j];
                    temp[abs(k - j)] += c[j];
                }
            }
            sum += a[I];  //简单优化一下
            for (int j = 0; j <= sum; ++j) {
                c[j] = temp[j];
                temp[j] = 0;
            }
        }
        for (int i = 0; i <= sum; ++i) {
            if (!c[i])
                ans.push_back(i);
        }
        cout << ans.size() << endl;
        if (!ans.empty()) {
            for (int i = 0; i < ans.size(); ++i) {
                if (i)
                    printf(" %d", ans[i]);
                else
                    printf("%d", ans[i]);
            }
            printf("\n");
        }
        
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值