hdu 2363 Cycling (最短路spfa + 暴力枚举)

Cycling

Time Limit: 5000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 114 Accepted Submission(s): 52
 
Problem Description
You want to cycle to a programming contest. The shortest route to the contest might be over the tops of some mountains and through some valleys. From past experience you know that you perform badly in programming contests after experiencing large differences in altitude. Therefore you decide to take the route that minimizes the altitude difference, where the altitude difference of a route is the difference between the maximum and the minimum height on the route. Your job is to write a program that finds this route.
You are given:

the number of crossings and their altitudes, and

the roads by which these crossings are connected.
Your program must find the route that minimizes the altitude difference between the highest and the lowest point on the route. If there are multiple possibilities, choose the shortest one.
For example:



In this case the shortest path from 1 to 7 would be through 2, 3 and 4, but the altitude difference of that path is 8. So, you prefer to go through 5, 6 and 4 for an altitude difference of 2. (Note that going from 6 directly to 7 directly would have the same difference in altitude, but the path would be longer!) 
 
Input
On the first line an integer t (1 <= t <= 100): the number of test cases. Then for each test case:

One line with two integers n (1 <= n <= 100) and m (0 <= m <= 5000): the number of crossings and the number of roads. The crossings are numbered 1..n.

n lines with one integer hi (0 <= h i <= 1 000 000 000): the altitude of the i-th crossing.

m lines with three integers a j , b j (1 <= a j , b j <= n) and c j (1 <= c j <= 1 000 000): this indicates that there is a two-way road between crossings a j and b j of length c j . You may assume that the altitude on a road between two crossings changes linearly.
You start at crossing 1 and the contest is at crossing n. It is guaranteed that it is possible to reach the programming contest from your home.
 
Output
For each testcase, output one line with two integers separated by a single space:

the minimum altitude difference, and

the length of shortest path with this altitude difference.
 
Sample Input
1
7 9
4
9
1
3
3
5
4
1 2 1
2 3 1
3 4 1
4 7 1
1 5 4
5 6 4
6 7 4
5 3 2
6 4 2
 
Sample Output
2 11
 
 
Source
bapc2007_pre
 
Recommend
lcy
 
把所有点的高度差都没举出来,从小到大排序,然后从小到大,求最短路。
#include <iostream>
#include <string.h>
#include <stdio.h>
#include <algorithm>
#include <queue>
#include <vector>
using namespace std;
constexpr int INF = 0x3fffffff;
int  n, m;
struct Altitude {
    int high;
    int low;
}altitude[10050];
struct Node {
    Node() = default;
    Node(int vv, int ww):v(vv), w(ww){}
    int v;
    int w;
};
vector<Node> map[105];
int a[105]; //各个点的高度
int dis[105];
int visited[105];
void spfa(int high, int low) {
    int v, u, w;
    for (int i = 1; i <= 100; ++i) {
        dis[i] = INF;
        visited[i] = 0;
    }
    if (a[1] < low || a[1] > high)//起点范围判断。
        return;
    dis[1] = 0;
    queue<int> que;
    que.push(1); // 从1开始
    visited[1] = 1;
    while (!que.empty()) {
        u = que.front();
        que.pop();
        visited[u] = 0;
            //cout << map[u].size() << endl;
        for (int i = 0; i < map[u].size(); ++i) {
            v = map[u][i].v;
            if (a[v] < low || a[v] > high)
                continue;
            w = map[u][i].w;
            
            if (dis[u] + w < dis[v]) {
                dis[v] = dis[u] + w;
                if (!visited[v]) {
                    que.push(v);
                    visited[v] = 1;
                }
            }
        }
    }
}


int main() {
    int t;
    cin >> t;
    while (t--) {
        for (int i = 0; i <= 100; ++i) {
            map[i].clear();
        }
        cin >> n >> m;
        for (int i = 1; i <= n; ++i) {
            cin >> a[i];
        }
        int k = 0;
        for (int i = 1; i <= n; ++i) {
            for (int j = i; j <= n; ++j) {
                altitude[k].high = max(a[i], a[j]);
                altitude[k++].low = min(a[i], a[j]);
            }
        }
        for (int i = 0; i < m; ++i) {
            int u, v, w;
            cin >> u >> v >> w;
            //implicit construct
            map[u].push_back({v, w});
            map[v].push_back({u, w});
        }
            //lambda function
        sort(altitude, altitude + k, [](Altitude a1, Altitude a2)->bool{return (a1.high - a1.low) < (a2.high - a2.low);});
        int i;
        for (i = 0; i < k; ++i) {
            spfa(altitude[i].high, altitude[i].low);
            if (dis[n] != INF) {
                break;
            }
        }
        cout << altitude[i].high - altitude[i].low << " " << dis[n] << endl;
        
    }
    
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值