Regular polygon(2017多校联赛2。 计算几何)

Regular polygon

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1047    Accepted Submission(s): 388


Problem Description
On a two-dimensional plane, give you n integer points. Your task is to figure out how many different regular polygon these points can make.
 

Input
The input file consists of several test cases. Each case the first line is a numbers N (N <= 500). The next N lines ,each line contain two number Xi and Yi(-100 <= xi,yi <= 100), means the points’ position.(the data assures no two points share the same position.)
 

Output
For each case, output a number means how many different regular polygon these points can make.
 

Sample Input
  
  
4 0 0 0 1 1 0 1 1 6 0 0 0 1 1 0 1 1 2 0 2 1
 

Sample Output
  
  
1 2
 

Source


 
给你的整数坐标点,判断 能组成多少正多边形。。。dfs?  naive
整数点能组成的正多边形形只有正方形了2333.  把所有的点hash一下暴力枚举两点求正方形的另外两点坐标,查询就可以了

#include <iostream>
#include <string>
#include <string.h>
#include <algorithm>
#include <array>
#include <cmath>
#include <vector>
#include <stdio.h>
using namespace std;
int n;
const int maxn = 505;
const int mod = 200;
struct P {
    int x, y;
}p[maxn];
int visited[maxn][maxn];
int ans;
void find(const P& p1, const P& p2) {
    int dx = p1.x - p2.x;
    int dy = p1.y - p2.y;
    if (p1.x + dy >= 0 && p1.y - dx >= 0 && p2.x + dy >= 0 && p2.y - dx >= 0) {
        if (visited[p1.x + dy][p1.y - dx] && visited[p2.x + dy][p2.y - dx])
            ans++;
    }
    if (p1.x - dy >= 0 && p1.y + dx >= 0 && p2.x - dy >= 0&& p2.y + dx >= 0) {
        if (visited[p1.x - dy][p1.y + dx] && visited[p2.x - dy][p2.y + dx])
            ans++;
    }
}
int main() {
        //freopen("1.txt", "r", stdin);
    while (cin >> n) {
        ans = 0;
        memset(visited, 0, sizeof(visited));
        for (int i = 0; i < n; ++i) {
            cin >> p[i].x >> p[i].y;
            p[i].x += mod;
            p[i].y += mod;
            visited[p[i].x][p[i].y] = 1;
        }
        for (int i = 0; i < n; ++i) {
            for (int j = i + 1; j < n; ++j) {
                find(p[i], p[j]);
            }
        }
        cout << ans / 4 << endl;
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值