hud6154 - CaoHaha's staff(2017ccpc网络赛。 找规律 + 递推)

CaoHaha's staff

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 514    Accepted Submission(s): 299


Problem Description
"You shall not pass!"
After shouted out that,the Force Staff appered in CaoHaha's hand.
As we all know,the Force Staff is a staff with infinity power.If you can use it skillful,it may help you to do whatever you want.
But now,his new owner,CaoHaha,is a sorcerers apprentice.He can only use that staff to send things to other place.
Today,Dreamwyy come to CaoHaha.Requesting him send a toy to his new girl friend.It was so far that Dreamwyy can only resort to CaoHaha.
The first step to send something is draw a Magic array on a Magic place.The magic place looks like a coordinate system,and each time you can draw a segments either on cell sides or on cell diagonals.In additional,you need 1 minutes to draw a segments.
If you want to send something ,you need to draw a Magic array which is not smaller than the that.You can make it any deformation,so what really matters is the size of the object.
CaoHaha want to help dreamwyy but his time is valuable(to learn to be just like you),so he want to draw least segments.However,because of his bad math,he needs your help.
 

Input
The first line contains one integer T(T<=300).The number of toys.
Then T lines each contains one intetger S.The size of the toy(N<=1e9).
 

Output
Out put T integer in each line ,the least time CaoHaha can send the toy.
 

Sample Input
  
  
5 1 2 3 4 5
 

Sample Output
  
  
4 4 6 6 7
 

Source
 

Recommend
liuyiding

只要能找到样例中的5个面积单位 7条边剩下的就好办了。5个斜边+2个正边组成的3个整正方形 + 5个三角形

推出来 边数           最大面积
              4                     2
              6                     4
              7                     5
              8                     8
              9                     10
              10                   12
              11                   14
              12                  18

#include <iostream>
#include <algorithm>
#include <string.h>
#include <stdio.h>
using namespace std;
int shit[1000000];
int main() {
    int b;
    shit[4] = 2;
    shit[6] = 4;
    shit[7] = 5;
    for (int i = 8; i <= 1000000; ++i) {
        if (i % 4 == 0) {
            b = i / 4;
            shit[i] = b * b * 2;
        } else if (i % 4 == 1) {
            shit[i] = b - 1 + shit[i - 1];
        } else if (i % 4 == 2) {
            shit[i] = b * 2 + shit[i - 2];
        } else {
            shit[i] = b + shit[i - 1];
        }
        if (shit[i] > 1e9) {
            break;
        }
    }
    int t;
    scanf("%d", &t);
    while (t--) {
        int x;
        scanf("%d", &x);
        for (int i = 4; i <= 1000000; ++i) {
            if (shit[i] >= x) {
                printf("%d\n", i);
                break;
            }
        }
    }
}

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值