NBUT 2012 Summer Training -1 / [B] Birdlike Angry Pig

  • [B] Birdlike Angry Pig

    问题描述
    There's no end to revenge.Pigs like to eat birds' eggs, so birds decide to revenge.For this, pigs decide to revenge as well.Pigs give a task to a birdlike pig. They let he sneak into the birds group so that they can destroy the birds group.

    Every bird has a ID number (It may not be unique). To let pigs know, the birdlike pig makes the "AND operation" amount all the birds' ID number and sign himself to the answer.

    For example:
    Birds are signed as 5, 3, 4. So the birdlike pig signs himself as (5 & 3 & 4 = 0).

    One day, a group birds pass by pigs' home. So the angry pig want to know whether the birdlike pig is in.

  • 输入
  • This problem has several cases. The first line of each case is an integer N (2 <= N <= 100 000).
  • Then follows a line with N integers, indicates the ID of each bird/birdlike pig.

  • 输出

  • For each case, if you can find the birdlike pig then output the ID of birdlike pig. Or output 'CAUTION: NO BIRDLIKE'.

  • 样例输入
    5
    4 0 3 4 5

  • 样例输出
  • 0

  • 分析:
  • 首先应该注意and运算的性质: 他有个必要条件:两个相同的数and后结果还等于那个数。因为最后就是birdlike和其他bird and 而birdlike又等于其他bird and后的结果,所以显然,如果存在birdlike,则birdlike的大小等于所有数从左往右and的结果。
  • 但是这只是一个必要条件,不是充分条件,所以还需额外判断一下。(前几次提交忘了。。。T^T)比如63&7=7,可能你光看前面会觉得7是birdlike,但实际上他不是。这就需要再扫描一遍,找到“可能的”birdlike值,然后判断他到底是不是birdlike。(他本身等于除去他后剩下所有数and的结果)。
  • #include <cstdio>
    #include <cmath>
    using namespace std;


    int main()
    {
        int n;
        int ans=0;
        int a[100005];
        while (scanf("%d",&n)!=EOF)
        {
            ans=2147483647;
            for (int i=0;i<n;i++)
            {
                scanf("%d",&a[i]);
                ans=ans&a[i];
            }
            int ok=0;
            for (int i=0;i<n;i++)
                if (a[i]==ans)
                {
                    int nn=2147483647;
                    for (int j=n-1;j>=0;j--)
                    {
                        if (j!=i)   nn=nn&a[j];
                    }
                    if (nn==ans)
                    {
                        printf("%d\n",ans);
                        ok=1;
                        break;
                    }
                }
            if (!ok) printf("CAUTION: NO BIRDLIKE\n");
        }
        return 0;
    }

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
SQLAlchemy 是一个 SQL 工具包和对象关系映射(ORM)库,用于 Python 编程语言。它提供了一个高级的 SQL 工具和对象关系映射工具,允许开发者以 Python 类和对象的形式操作数据库,而无需编写大量的 SQL 语句。SQLAlchemy 建立在 DBAPI 之上,支持多种数据库后端,如 SQLite, MySQL, PostgreSQL 等。 SQLAlchemy 的核心功能: 对象关系映射(ORM): SQLAlchemy 允许开发者使用 Python 类来表示数据库表,使用类的实例表示表中的行。 开发者可以定义类之间的关系(如一对多、多对多),SQLAlchemy 会自动处理这些关系在数据库中的映射。 通过 ORM,开发者可以像操作 Python 对象一样操作数据库,这大大简化了数据库操作的复杂性。 表达式语言: SQLAlchemy 提供了一个丰富的 SQL 表达式语言,允许开发者以 Python 表达式的方式编写复杂的 SQL 查询。 表达式语言提供了对 SQL 语句的灵活控制,同时保持了代码的可读性和可维护性。 数据库引擎和连接池: SQLAlchemy 支持多种数据库后端,并且为每种后端提供了对应的数据库引擎。 它还提供了连接池管理功能,以优化数据库连接的创建、使用和释放。 会话管理: SQLAlchemy 使用会话(Session)来管理对象的持久化状态。 会话提供了一个工作单元(unit of work)和身份映射(identity map)的概念,使得对象的状态管理和查询更加高效。 事件系统: SQLAlchemy 提供了一个事件系统,允许开发者在 ORM 的各个生命周期阶段插入自定义的钩子函数。 这使得开发者可以在对象加载、修改、删除等操作时执行额外的逻辑。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值