L - Master-Mind Hints UVA - 340

MasterMind is a game for two players. One of them, Designer, selects a secret code. The other, Breaker,tries to break it. A code is no more than a row of colored dots. At the beginning of a game, the playersagree upon the length N that a code must have and upon the colors that may occur in a code.In order to break the code, Breaker makes a number of guesses, each guess itself being a code. Aftereach guess Designer gives a hint, stating to what extent the guess matches his secret code.In this problem you will be given a secret code s1 . . . sn and a guess g1 . . . gn, and are to determinethe hint. A hint consists of a pair of numbers determined as follows.A match is a pair (i, j), 1 ≤ i ≤ n and 1 ≤ j ≤ n, such that si = gj . Match (i, j) is called strongwhen i = j, and is called weak otherwise. Two matches (i, j) and (p, q) are called independent wheni = p if and only if j = q. A set of matches is called independent when all of its members are pairwiseindependent.Designer chooses an independent set M of matches for which the total number of matches and thenumber of strong matches are both maximal. The hint then consists of the number of strong followedby the number of weak matches in M. Note that these numbers are uniquely determined by the secretcode and the guess. If the hint turns out to be (n, 0), then the guess is identical to the secret code.InputThe input will consist of data for a number of games. The input for each game begins with an integerspecifying N (the length of the code). Following these will be the secret code, represented as N integers,which we will limit to the range 1 to 9. There will then follow an arbitrary number of guesses, eachalso represented as N integers, each in the range 1 to 9. Following the last guess in each game will beN zeroes; these zeroes are not to be considered as a guess.Following the data for the first game will appear data for the second game (if any) beginning with anew value for N. The last game in the input will be followed by a single ‘0’ (when a value for N wouldnormally be specified). The maximum value for N will be 1000.OutputThe output for each game should list the hints that would be generated for each guess, in order, one hintper line. Each hint should be represented as a pair of integers enclosed in parentheses and separated bya comma. The entire list of hints for each game should be prefixed by a heading indicating the gamenumber; games are numbered sequentially starting with 1. Look at the samples below for the exactformat.Sample Input41 3 5 51 1 2 34 3 3 56 5 5 16 1 3 51 3 5 50 0 0 0101 2 2 2 4 5 6 6 6 91 2 3 4 5 6 7 8 9 11 1 2 2 3 3 4 4 5 51 2 1 3 1 5 1 6 1 91 2 2 5 5 5 6 6 6 70 0 0 0 0 0 0 0 0 00Sample OutputGame 1:(1,1)(2,0)(1,2)(1,2)(4,0)Game 2:(2,4)(3,2)(5,0)(7,0)
#include <algorithm>
#include <iostream>
#include <cstdlib>
#include <cstring>
#include<stdio.h>
using namespace std;


int main()
{
    int a[1001];
    int b[1001];
    int c[1001];
    int d[1001];
    int n,i;
    int j,k,m,m1;
    int s;
    int t=0;
    while(scanf("%d",&n),n!=0)
    {
        t++;
        printf("Game %d:\n",t);
        for(i=0; i<n; i++)
            scanf("%d",&a[i]);
        while(1)
        {
            memset(c,0,sizeof(c));
            memset(d,0,sizeof(d));
            m=0,m1=0;
            s=0;
            for(i=0; i<n; i++)
            {
                scanf("%d",&b[i]);
                if(b[i]==0)
                    s++;
            }
            if(s==n)
                break;
            for(i=0; i<n; i++)
            {
                if(a[i]==b[i])
                {
                    b[i]=-1;
                    m++;
                    c[i]=1;
                    d[i]=1;
                }
            }
            for(i=0; i<n; i++)
            {
                for(j=0; j<n; j++)
                {
                    if(a[i]==b[j]&&c[i]==0&&d[j]==0)
                    {
                        m1++;
                        c[i]=1;
                        d[j]=1;
                        break;
                    }
                }
            }
            printf("    (%d,%d)\n",m,m1);
        }
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值