集训笔记---尺取法(POJ NO.3061 Subsequence)

8 篇文章 0 订阅

Subsequence

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 20474 Accepted: 8738

Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3

首先确定一个大区间,然后让毛毛虫在区间上从头开始遍历一遍,s的递增代表着毛毛虫的迁移,最终毛毛虫将覆盖到每一个解区间,从中选取最短的一个即可

#include<cstdio>
#include<algorithm>
using namespace std;
const int MAX_N = 100010;
int a[MAX_N], sum[MAX_N];
int main(void)
{
    int t, n, m, i, s, h;
    scanf("%d", &h);
    while(h--)
    {
        scanf("%d %d", &n, &m);
        for(i = 0; i < n; i++)
        {
            scanf("%d", &a[i]);
            sum[i+1] = sum[i] + a[i];//T~S连续序列的和其实可以用sum[t]-sum[s]表示
            //sum[i]表示数组前i项的和 
        }
        int res = n;//首先确定最大区间1~N; 
        t = 0;
        for(s = 0; sum[s] + m < sum[n]; s++)//利用尺取法让毛毛虫从初始状态开始蠕动 
        {
            //使用二分法寻求每一个S所对应的最短的T 
            t = lower_bound(sum+s, sum+n, sum[s]+m) - sum;
            res = min(res, t-s);
        }
        if(res == n)//如果res == n仍然成立,说明sum[n] < m,即在这个实例中题目无解 
        {
            res = 0;
        }
        printf("%d\n", res);
    }
    return 0;
    

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值