Catch That Cow
Time Limit: 5000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 19774 Accepted Submission(s): 5805
Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.
* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.
If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
Source
dfs明显会超时,用bfs写在大佬郭聚聚指导下学会了bfs,可是用郭聚聚方法疯狂re,可能是oj针对我吧;
和聚聚聊天中突然想到可以不用结构体做,直接每次将两个元素穿进队列里面就ok
下面附上蒟蒻代码
#include <bits/stdc++.h>
#define ma 100010
typedef long long ll;
using namespace std;
int bfs(ll x,ll y)
{
queue<ll>q;
q.push(x);
q.push(0);
bool seen[ma] = {0};
while(!q.empty())
{
ll num = q.front();
q.pop();
ll step = q.front();
q.pop();
if(num == y)
{
return step;
}
else
{
if(num - 1 >= 0 && !seen[num-1])
{
seen[num-1] = 1;
q.push(num-1);
q.push(step+1);
}
if(num * 2 <= ma && !seen[num*2])
{
seen[num*2] = 1;
q.push(num*2);
q.push(step+1);
}
if(num + 1 <= ma && !seen[num+1])
{
seen[num+1] = 1;
q.push(num+1);
q.push(step+1);
}
}
}
}
int main()
{
ll n,m;
while(cin >> n >> m)
{
cout << bfs(n,m) << endl;
}
return 0;
}