winXP sp2 MDAC 2.8 安装问题解决方法

 
winXP sp2 MDAC 2.8 安装问题解决方法

 
在windows xp + sp2 环境下安装过程中出现提示:“mdac 2.8 Rtm 与此版本 windows 不兼容”。解决办法:现在MDAC2.8的所有功能都成为 windows XP sp2的一部分,该提示正常,不会影响使用。
因为你的系统是WINXP-SP2,系统自带MDAC 2.8 SP2,所以不能安装MDAC 2.8,而且WINXP-SP2不能卸载MDAC,它是系统的核心部件,只能通过安装SERVICE PACK 的后续版本升级你的MDAC,并且不能往回滚动到以前版本的MDAC.

如果你安装下载了MDAC 微软数据访问组件版本2.8,安装到WINXP SP2的机器,你将收到如下错误信息:
This version is incompatible with the version you are attempting to install.(这个版本mdac 2.8 Rtm 和你的WINDOWS不兼容 你的系统版本和你准备安装的软件版本不兼容)

2. MDAC 2.81 安装方法1
参考 http://msdn.microsoft.com/data/mdac/downloads/default.aspx (这是关于如何安装MDAC 2.81 信息,这个MDAC2.8 SP1分发安装包和WINXP SP2附带安装的是同一数据访问组件)

3. MDAC 2.8 安装方法2
修补WINXP SP2自带的MDAC 2.81安装
如果你不能看得WINDOWS的INF目录,做如下步骤:
点击 开始->我的计算机->工具菜单->文件夹->选项
点击 查看
在高级设置下,点击 显示隐藏档和档夹
去掉隐藏已知文件的扩展名选项
点击应用 点击确认
在WINDOWS的INF目录下,右键点击MDAC.INF,选择 安装
当提示你插入WINXP SP2光盘的时候,选择如下方法 插入光盘到光驱
如果出现欢迎使用WINXP提示信息,点击 退出
点击浏览按钮
在文件名称输入光驱盘符,包含 I386目录 如果你的光驱是D盘,输入
点击打开
或者直接输入 %systemroot%/windows/servicepackfiles/i386 点击打开
可能还会提示你插入WINXP SP2光盘进行系统安装,同上步骤估计这样的话,应该也可以解决 ADO数据库访问的问题了吧

MDAC 2.8 SP1 版所安装的数据访问核心组件与 Microsoft SQL Server OLE DB Provider, ODBC Driver 相同。 MDAC 2.8 SP1 最终发行的可再分发安装程序安装与 Microsoft Windows XP SP2 一样的 Data Access 的核心组件。 http://support.microsoft.com/default.aspx?scid=kb;en-us;899861?此版本不包括 Microsoft Jet、Microsoft Jet OLE DB Provider、Desktop Database Drivers ODBC Driver 或 Visual FoxPro ODBC Driver。

reference: http://blog.csdn.net/fbysss/archive/2006/02/05/592539.aspx?Pending=true
评论 1 您还未登录,请先 登录 后发表或查看评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
©️2022 CSDN 皮肤主题:大白 设计师:CSDN官方博客 返回首页

打赏作者

三杯倒

你的鼓励将是我创作的最大动力

¥2 ¥4 ¥6 ¥10 ¥20
输入1-500的整数
余额支付 (余额:-- )
扫码支付
扫码支付:¥2
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值