杭电OJ-1036_Average is not Fast Enough!

昨天家里来了几个小朋友,和我抢电脑,我输了,

今天在其拳打脚踢的情况下艰难的AC了

这道题主要要解决的是输入输出的格式控制,还有一个舍入问题

不说了,贴个代码,电脑让他


Average is not Fast Enough!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4775    Accepted Submission(s): 1929


Problem Description
A relay is a race for two or more teams of runners. Each member of a team runs one section of the race. Your task is to help to evaluate the results of a relay race.

You have to process several teams. For each team you are given a list with the running times for every section of the race. You are to compute the average time per kilometer over the whole distance. That's easy, isn't it?
So if you like the fun and challenge competing at this contest, perhaps you like a relay race, too. Students from Ulm participated e.g. at the "SOLA" relay in Zurich, Switzerland. For more information visit http://www.sola.asvz.ethz.ch/ after the contest is over.
 

Input
The first line of the input specifies the number of sections n followed by the total distance of the relay d in kilometers. You may safely assume that 1 <= n <= 20 and 0.0 < d < 200.0. Every following line gives information about one team: the team number t (an integer, right-justified in a field of width 3) is followed by the n results for each section, separated by a single space. These running times are given in the format "h:mm:ss" with integer numbers for the hours, minutes and seconds, respectively. In the special case of a runner being disqualified, the running time will be denoted by "-:--:--". Finally, the data on every line is terminated by a newline character. Input is terminated by EOF.
 

Output
For each team output exactly one line giving the team's number t right aligned in a field of width 3, and the average time for this team rounded to whole seconds in the format "m:ss". If at least one of the team's runners has been disqualified, output "-" instead. Adhere to the sample output for the exact format of presentation.
 

Sample Input
  
  
2 12.5 5 0:23:21 0:25:01 42 0:23:32 -:--:-- 7 0:33:20 0:41:35
 

Sample Output
  
  
5: 3:52 min/km 42: - 7: 6:00 min/km


#include<iostream>
using namespace std;
int n, t, *m, *s,sign,time,speed;
char *h;
double d;


void input()
{
	for (int i = 0; i < n; i++)
	{
		cin >> h[i];
		if (h[i] == '-')
		{
			sign = 1;
			for (int j = 0; j < 6; j++)
				cin.get();
		}
		else
		{
			time += ((int)h[i] - 48) * 60 * 60;
			cin.get();
			cin >> m[i];
			time += m[i] * 60;
			cin.get();
			cin >> s[i];
			time += s[i];
		}
	}
}

void output()
{
	if (t >= 0 && t <= 9)
		cout << "  " << t << ": ";
	else if (t > 9 && t <= 99)
		cout << ' ' << t << ": ";
	else
		cout << t << ": ";
	if (sign == 0)
	{
		speed = time / d;
		if (time / d - speed >= 0.5)
			speed++;
		cout << speed / 60 << ':';
		if (speed % 60 >= 0 && speed % 60 <= 9)
			cout << '0' << speed % 60 << " min/km" << endl;
		else
			cout << speed % 60 << " min/km" << endl;
	}
	else
		cout << "-\n";
}
int main(void)
{
	cin >> n >> d;
	h = new char[n];
	m = new int[n];
	s = new int[n];	
	while (cin>>t)
	{
		sign = 0;
		time=0;
		input();
		output();
	}
	return 0;
}


杭州电子科技大学在线评测系统(杭电OJ)中的题目1000-1100是一系列编程题,我将分别进行回答。 1000题是一个简单的入门题,要求计算两个整数的和。我们可以使用一个简单的算法,读取输入的两个整数,然后将它们相加,最后输出结果即可。 1001题是一个稍微复杂一些的题目,要求实现字符串的逆序输出。我们可以使用一个循环来逐个读取输入的字符,然后将这些字符存储在一个数组中。最后,我们可以倒序遍历数组并将字符依次输出,实现字符串的逆序输出。 1002题是一个求最大公约数的问题。我们可以使用辗转相除法来解决,即先求出两个数的余数,然后将被除数更新为除数,将除数更新为余数,直至两个数的余数为0。最后的被除数就是最大公约数。 1003题是一个比较简单的排序问题。我们可以使用冒泡排序算法来解决,即每次比较相邻的两个元素,如果它们的顺序错误就交换它们的位置。重复这个过程直至整个数组有序。 1100题是一个动态规划问题,要求计算给定序列中的最长上升子序列的长度。我们可以使用一个数组dp来保存到达每个位置的最长上升子序列的长度。每当遍历到一个位置时,我们可以将其和之前的位置比较,如果比之前位置的值大,则将其更新为之前位置的值加1,最后返回dp数组的最大值即可。 以上是对杭电OJ1000-1100题目的简要回答,涉及了一些基本的编程知识和算法思想。希望对您有所帮助。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值