HDU 1036 Average is not Fast Enough! (水题)

Average is not Fast Enough!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6475    Accepted Submission(s): 2730


Problem Description
A relay is a race for two or more teams of runners. Each member of a team runs one section of the race. Your task is to help to evaluate the results of a relay race. 

You have to process several teams. For each team you are given a list with the running times for every section of the race. You are to compute the average time per kilometer over the whole distance. That's easy, isn't it? 
So if you like the fun and challenge competing at this contest, perhaps you like a relay race, too. Students from Ulm participated e.g. at the "SOLA" relay in Zurich, Switzerland. For more information visit http://www.sola.asvz.ethz.ch/ after the contest is over.
 

Input
The first line of the input specifies the number of sections n followed by the total distance of the relay d in kilometers. You may safely assume that 1 <= n <= 20 and 0.0 < d < 200.0. Every following line gives information about one team: the team number t (an integer, right-justified in a field of width 3) is followed by the n results for each section, separated by a single space. These running times are given in the format "h:mm:ss" with integer numbers for the hours, minutes and seconds, respectively. In the special case of a runner being disqualified, the running time will be denoted by "-:--:--". Finally, the data on every line is terminated by a newline character. Input is terminated by EOF.
 

Output
For each team output exactly one line giving the team's number t right aligned in a field of width 3, and the average time for this team rounded to whole seconds in the format "m:ss". If at least one of the team's runners has been disqualified, output "-" instead. Adhere to the sample output for the exact format of presentation.
 

Sample Input
  
  
2 12.5 5 0:23:21 0:25:01 42 0:23:32 -:--:-- 7 0:33:20 0:41:35
 

Sample Output
  
  
5: 3:52 min/km 42: - 7: 6:00 min/km
 

Source

University of Ulm Local Contest 2001


题目大意:给出一队赛跑的队员数以及赛跑的路程,求出所有队员所用时间总和的平均速度;如样例:2表示每队有两名队员,12.5表示路程,5、42、7表示队伍编号(无用),后面的时间分别表示每个队员所用的时间,“-”则表示队员不合格。


这一题看上去很复杂,我刚拿到题的时候在稿纸上算了很多遍,总以为题意给的是开始时间和结束时间,后来又仔细读了一下题目,才了解了题目的意思;

总体来说是一道水题,只需要将所有时间相加然后除以路程即可,因为存在不合格情况,所以不能直接定义int型,而是用char型进行间接转换;

最大的难点在于格式输出,留的空格数以及空格补不补0是最需要注意的,否则很容易就会PE。


#include <iostream>
#include <cstdio>
#include <cstdlib>
using namespace std;
int main(){
    int n;
    double mile;
    scanf("%d%lf",&n,&mile);
    int number;
    char s[7];
    while(~scanf("%d",&number)){
        printf("%3d:",number);//注意输出格式
        double sum=0;
        bool flag=true;
        for(int i=0;i<n;i++){
            scanf("%s",s);
            if(s[0]=='-'&&flag==true)//判断是否合格
                flag=false;
            else
                sum+=(s[0]-'0')*3600+((s[2]-'0')*10+s[3]-'0')*60+(s[5]-'0')*10+(s[6]-'0');//将char型转化为int型并进行求和
        }
        if(flag){
            int x=(sum/mile+0.5)/60;//将结果进行四舍五入求出m
            int y=(int)(sum/mile+0.5)%60;//将结果四舍五入求出s
            printf("%2d:%02d min/km\n",x,y);//注意输出格式
        }
        else
            printf(" -\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值