杭电ACM题 1036 Edge解题报告

这篇博客介绍了杭电ACM竞赛中一道编号为1036的简单题目,即‘Edge’。博主指出,题目理解上可能存在困扰,实际上题目要求在接收到字母'A'时向右转,'V'时向左转,并每次移动10个单位。通过设置方向变量和坐标记录,博主成功解决了问题。初次提交时因字符串数组大小不足导致错误,调整为200后代码顺利通过。
摘要由CSDN通过智能技术生成
Edge
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 1157 Accepted: 811

Description

For products that are wrapped in small packings it is necessary that the sheet of paper containing the directions for use is folded until its size becomes small enough. We assume that a sheet of paper is rectangular and only folded along lines parallel to its initially shorter edge. The act of folding along such a line, however, can be performed in two directions: either the surface on the top of the sheet is brought together, or the surface on its bottom. In both cases the two parts of the rectangle that are separated by the folding line are laid together neatly and we ignore any differences in thickness of the resulting folded sheet.

After several such folding steps have been performed we may unfold the sheet again and take a look at its longer edge holding the sheet so that it appears as a one-dimensional curve, actually a concatenation of line segments. If we move along this curve in a fixed direction we can classify every place where the sheet was folded as either type A meaning a clockwise turn or type V meaning a counter-clockwise turn. Given such a sequence of classifications, produce a drawing of the longer edge of the sheet assuming 90 degree turns at equidistant places.

Input

The input contains several test cases, each on a separate line. Each line contains a nonempty string of characters A and V describing the longer edge of the sheet. You may assume that the length of the string is less than 200. The input file terminates immediately after the last test case.

Output

For each test case generate a PostScript drawing of the edge with commands placed on separate lines. Start every drawing at the coordinates (300,420) with the command "300 420 moveto". The first turn occurs at (310,420) using the command "310 420 lineto". Continue with clockwise or counter-clockwise turns according to the input string, using a sequence of "x y lineto" commands with the appropriate coordinates. The turning points are separated at a distance of 10 units. Do not forget the end point of the edge and finish each test case by the commands stroke and showpage.

You may display such drawings with the gv PostScript interpreter, optionally after a conversion using the ps2ps utility.

Sample Input

V
AVV

Sample Output

300 420 moveto
310 420 lineto
310 430 lineto
stroke
showpage
300 420 moveto
310 420 lineto
310 410 lineto
320 410 lineto
320 420 lineto
stroke
showpage

Source

/

这题不难,就是题目看的比较蛋疼,其实就是当输入A时右转,V的时候左转,每次转后需要走10单位。

我设置了一个方向direc变量,用于记录当前的位置,用x和y记录坐标。我提交两次,一次RE,修改了string数组的大小,本来是20,改成200后就行了。

AC代码:

/***********************
*   程序名:Edge.cpp
*   功能:ACM
************************/

#include <iostream>
#include <Cstring>
using namespace std;
#define start_x 300
#define start_y 420
#define move 10
int main()
{
    char c, string[200];
    int length, i, x, y;
    char direc;
    while(cin>>string) {
        direc = 'r';
        x = start_x + move;
        y = start_y;
        length = strlen(string);
        cout<<start_x<<" "<<start_y<<" "<<"moveto"<<endl;
        cout<<start_x+move<<" "<<start_y<<" "<<"lineto"<<endl;
        for(i = 0; i < length; i++) {
            if(string[i] == 'V') {
                if(direc == 'r') {
                    direc = 'u';
                    y += move;
                    cout<<x<<" "<<y<<" "<<"lineto"<<endl;
                }
                else if(direc == 'l'){
                    direc = 'd';
                    y -= move;
                    cout<<x<<" "<<y<<" "<<"lineto"<<endl;
                }
                else if(direc == 'u') {
                    direc = 'l';
                    x -= move;
                    cout<<x<<" "<<y<<" "<<"lineto"<<endl;
                }
                else {
                    direc = 'r';
                    x += move;
                    cout<<x<<" "<<y<<" "<<"lineto"<<endl;
                }
            }
            else if(string[i] == 'A') {
                if(direc == 'r') {
                    direc = 'd';
                    y -= move;
                    cout<<x<<" "<<y<<" "<<"lineto"<<endl;
                }
                else if(direc == 'l') {
                    direc = 'u';
                    y += move;
                    cout<<x<<" "<<y<<" "<<"lineto"<<endl;
                }
                else if(direc == 'u') {
                    direc = 'r';
                    x += move;
                    cout<<x<<" "<<y<<" "<<"lineto"<<endl;
                }
                else {
                    direc = 'l';
                    x -= move;
                    cout<<x<<" "<<y<<" "<<"lineto"<<endl;
                }
            }
        }
        cout<<"stroke"<<endl<<"showpage"<<endl;
    }
    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值