3-7 类的友元函数的应用

卡了一上午的题,交上总是编译错误,编译错误,编译错误。

真是shit, 原来函数重名,我用的distance在c++库中有函数模板存在,改一下函数名就好了。

3-7 类的友元函数的应用

Time Limit: 1000MS  Memory Limit: 65536KB
Problem Description
通过本题目的练习可以掌握类的友元函数的定义和用法
要求设计一个点类Point,它具有两个double型的数据成员x,y。为该类设计构造函数。并为其添加一个友元函数用于计算并输出两点间的距离;再添加一个输出成员函数用于输出点的信息。
 
 
并编写主函数,实现以下的输入输出内容。
Input

4double型的数,中间用一个空格间隔。

Output

输出数据共3行,前两行用于显示要求距离的两个点的信息,第三行显示两点的距离。

Example Input
5 6 2 3
Example Output
The first point is the coordinate:X=5,Y=6
The second point is the coordinate:X=2,Y=3
The distance between the two points is:4.24264
Author
 黄晶晶

#include<iostream>
#include<algorithm>
#include<string>
#include<cmath>

using namespace std;

class Point
{
private:
    double x, y;
public:
    friend void distane(Point &a, Point &b);
    Point(double p, double q)
    {
        x=p;
        y=q;
    }
    void display()
    {
        cout<<" point is the coordinate:X="<<x<<",Y="<<y<<endl;
    }
};

void distane(Point &a, Point &b)
{
    cout<<"The distance between the two points is:"<<pow((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y), 0.5)<<endl;
}


int main()
{
    ios::sync_with_stdio(false);
    double a, b, c, d;
    cin>>a>>b>>c>>d;
    Point P1(a, b);
    Point P2(c, d);
    cout<<"The first";
    P1.display();
    cout<<"The second";
    P2.display();
    distane(P1, P2);
    return 0;
}

///distance (InputIterator first, InputIterator last); 在c++中,distance为一函数模版,返回两个迭代器间的距离。


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

西杭

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值