I - Expanding Rods解题报告(黄杰)

I - Expanding Rods
Time Limit:1000MS     Memory Limit:30000KB     64bit IO Format:%I64d & %I64u

Description

When a thin rod of length L is heated n degrees, it expands to a new length L'=(1+n*C)*L, where C is the coefficient of heat expansion. 
When a thin rod is mounted on two solid walls and then heated, it expands and takes the shape of a circular segment, the original rod being the chord of the segment. 

Your task is to compute the distance by which the center of the rod is displaced. 

Input

The input contains multiple lines. Each line of input contains three non-negative numbers: the initial lenth of the rod in millimeters, the temperature change in degrees and the coefficient of heat expansion of the material. Input data guarantee that no rod expands by more than one half of its original length. The last line of input contains three negative numbers and it should not be processed.

Output

For each line of input, output one line with the displacement of the center of the rod in millimeters with 3 digits of precision. 

Sample Input

1000 100 0.0001
15000 10 0.00006
10 0 0.001
-1 -1 -1

Sample Output

61.329
225.020
0.000

题目大意:一个长度为L的杆,在温度n下,会扩展到一个新长度L'=(1+n*C)*L,c为形变系数,题目要求计算如图扩展后,拉长杆的中心与圆杆中心的距离,输入为-1,-1,-1则退出程序。
题目链接:http://poj.org/problem?id=1905
方法:二分法
思路:这个就很简单啦,二分的对象显然是中心的距离,然后通过中心距离和圆杆长来计算扩展后的长度(不要告诉我你不会算--),在比较实际扩展的长度,这样就行了,注意精确度。
算法实现:

#include<stdio.h>
#include<math.h>
int main()
{
	double l,n,c,L,r,len;
	double low,high,mid;
	while(scanf("%lf%lf%lf",&l,&n,&c)!=EOF)
	{
		if(l<0&&n<0&&c<0)
			break;
		else
		{
			low=0;
			L=(1+n*c)*l;
			high=l/2;
			while(high-low>=1e-5)
			{
				mid=(low+high)/2.0;//由mid和l求出此时的理论长度len,然后进行比较。
				r=l*l/(8*mid)+mid/2;
				len=2*r*asin(l/(2*r));
				if(len>=L)
					high=mid;
				else
					low=mid;

			}
			printf("%.3lf\n",mid);
		}
	}
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值