ACM - Expanding Rods

Expanding Rods

*When a thin rod of length L is heated n degrees, it expands to a new length L’=(1+n*C)L, where C is the coefficient of heat expansion.When a thin rod is mounted on two solid walls and then heated, it expands and takes the shape of a circular segment, the original rod being the chord of the segment.Your task is to compute the distance by which the center of the rod is displaced.
在这里插入图片描述

Input
The input contains multiple lines. Each line of input contains three non-negative numbers: the initial lenth of the rod in millimeters, the temperature change in degrees and the coefficient of heat expansion of the material. Input data guarantee that no rod expands by more than one half of its original length. The last line of input contains three negative numbers and it should not be processed.

Output
For each line of input, output one line with the displacement of the center of the rod in millimeters with 3 digits of precision.

Sample Input
1000 100 0.0001
15000 10 0.00006
10 0 0.001
-1 -1 -1

Sample Output
61.329
225.020
0.000

二分答案:
答案确定了精度,可以二分答案。在运算过程中从答案入手,即从m入手,反向确定L’。
二分答案特征:
1.有最大值最小值区间。
2.二分过程存在单调性,并利用单调性。
3.求最大值的最小,或求最小值的最大。

对此题如果直接利用几何关系运算会比较麻烦,但m与L’存在单调性。(物理直觉上感知)故利用单调性二分答案。
在这里插入图片描述
代码:

#include<iostream>
#include<algorithm>
#include<vector>
#include<string>
#include<stack>
#include<cstring>
#include<cstdio>
#include<list>
#include<map>
#include<cmath>
using namespace std;

double l, n;
double c, l_, l2;
double L, R, m;

int main()
{
	while (cin >> l >> n >> c)
	{
		if (l < 0 && n < 0 && c < 0)break;
		L = 0;
		R = l / 2;
		l_ = (1 + n * c) * l;
		while (R - L > 1e-5)
		{
			m = (L + R) / 2;
			double r = m / 2 + l * l / m / 8;
			l2 = 2 * r * asin(l / r / 2);
			if (l2 < l_) L = m;  // 利用单调性,说明此m小了
			else R = m;
		}
		printf("%.3f\n", L);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值