F - Expanding Rods POJ 1905

F - Expanding Rods

Time Limit:500MS Memory Limit:32768KB 64bit IO Format:%lld & %llu
Submit

Status
Description
When a thin rod of length L is heated n degrees, it expands to a new length L’ = (1+n*C)*L, where C is the coefficient of heat expansion.

这里写图片描述

When a thin rod is mounted on two solid walls and then heated, it expands and takes the shape of a circular segment, the original rod being the chord of the segment.

Your task is to compute the distance by which the center of the rod is displaced. That means you have to calculate h as in the picture.

Input
Input starts with an integer T (≤ 20), denoting the number of test cases.

Each case contains three non-negative real numbers: the initial length of the rod in millimeters L, the temperature change in degrees n and the coefficient of heat expansion of the material C. Input data guarantee that no rod expands by more than one half of its original length. All the numbers will be between 0 and 1000 and there can be at most 5 digits after the decimal point.

Output
For each case, print the case number and the displacement of the center of the rod in single line. Errors less than 10-6 will be ignored.

Sample Input
3
1000 100 0.0001
150 10 0.00006
10 0 0.001
Sample Output
Case 1: 61.3289915
Case 2: 2.2502024857
Case 3: 0


  1. 题意:给定图形,公式如上,计算一个量。
  2. 思路:建立方程,二分求解。用二分函数需要单调,而且函数一般都单调,用二分法枚举出定义域内的值进行判断。
  3. 失误:将r看成了自变量,计算好烦,还算不出来,学了十几年数学应该总结出用角来做自变量的好处了。’
  4. 代码如下:
#include<cstdio>
#include<cmath>
#define PI acos(-1.0)
#define esp 1e-9
int main()
{
    int t,k=0,freq;
    double right,mid,left,L,C,L1,N,h;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lf%lf%lf",&L,&N,&C);
        L1=(1+N*C)*L;

        left=0.0,right=PI/2.0;//初始值,自变量的定义域(闭区间) 
        freq=100;
        while(freq--)
        {
            mid=(left+right)/2.0;//对角进行枚举 
            if(L*mid/sin(mid)>L1)//函数x/sin(x)在[0,PI/2]内递增 
            {
                right=mid-esp;
            }
            else
            {
                left=mid+esp;
            }
         } 
         h=L*(1.0-cos(mid))/2.0/sin(mid);//角度算出来后 计算相应的h 
         printf("Case %d: ",++k);
         printf("%.6lf\n",h); //四舍五入 
    }
    return 0;
 } 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值