hdu 2955 Robberies【经典01背包】

67 篇文章 0 订阅
20 篇文章 0 订阅

DP(关于抢银行概率的那道==) 

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2955

Robberies

Time Limit: 2000/1000 MS(Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s):4778    Accepted Submission(s): 1808


Problem Description

The aspiringRoy the Robberhas seen a lot of American movies, and knows that the bad guys usually getscaught in the end, often because they become too greedy. He has decided to workin the lucrative business of bank robbery only for a short while, beforeretiring to a comfortable job at a university.


For a few months now, Royhas been assessing the security of various banks and the amount of cash theyhold. He wants to make a calculated risk, and grab as much money as possible.


His mother, Ola, has decided upon a tolerable probability of getting caught.She feels that he is safe enough if the banks he robs together give a probabilityless than this.

 

 

Input

The first line of input gives T, the number of cases. Foreach scenario, the first line of input gives a floating point number P, theprobability Royneeds to be below, and an integer N, the number of banks he has plans for. Thenfollow N lines, where line j gives an integer Mj and a floating point number Pj. 
Bank j contains Mj millions, and the probability of getting caught from robbingit is Pj .

 

 

Output

For each test case, output a line with the maximum numberof millions he can expect to get while the probability of getting caught isless than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume thatall probabilities are independent as the police have very low funds.

 

 

Sample Input

3

0.04 3

1 0.02

2 0.03

3 0.05

0.06 3

2 0.03

2 0.03

3 0.05

0.10 3

1 0.03

2 0.02

3 0.05

 

 

Sample Output

2

4

6

 

 

Source

IDI Open 2009

 

//用dp[i]表示偷价值为i时不被抓的概率,则状态转移方程为:dp[i]=max(dp[i],dp[i-m]*(1-p));
//AC 78ms 332k(by C) 62ms 360k(by C++)
#include<stdio.h>
#include<string.h>
double dp[10005];          //因为n的最大值为100,mj的最大值也为100,所以数组要开得比10000大
int main()
{
	int test;               //测试数据组数
	double p,pj[105];  //p表示总共不能超过的被抓概率,pj表示抢劫相应的银行被抓的概率,注意:抢劫各个银行被抓的概率相互独立
	int n,mj[105];     //n表示此次可抢劫的银行数,mj表示从相应的银行能抢到的钱
	int i,j,sum;           //sum记录钱
	scanf("%d",&test);
	while(test--)
	{
		sum=0;
		memset(dp,0,sizeof(dp));
		dp[0]=1;           //dp的下表即抢的钱数,他的值,表示抢劫相应的钱后,逃跑的概率,还未抢劫时:钱为0,逃跑的概率为1
		scanf("%lf%d",&p,&n);
		for(i=0;i<n;i++)
		{
			scanf("%d%lf",&mj[i],&pj[i]);
			sum+=mj[i];
		}
		for(i=0;i<n;i++)
			for(j=sum;j>=mj[i];j--)
			{
				if(dp[j]<(dp[j-mj[i]]*(1-pj[i])))//状态转移方程,由各个概率相互独立所得
					dp[j]=dp[j-mj[i]]*(1-pj[i]);
//在总的抢劫价值都是j的情况下,如果抢劫第i个银行了,不被抓的概率大于原来没有抢第i个银行的概率的情况下,就dp[j]=dp[j-mj[i]]*(1-pj[i]);表示抢劫第i个银行,否则查找下一个银行。
			}
		for(i=sum;i>=0;i--)
			if(dp[i]>=(1-p))
			{
				printf("%d\n",i);
				break;
			}
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值