HDU 1397 Goldbach's Conjecture

Goldbach's Conjecture

Problem Description
Goldbach's Conjecture: For any even number n greater than or equal to 4, there exists at least one pair of prime numbers p1 and p2 such that n = p1 + p2.
This conjecture has not been proved nor refused yet. No one is sure whether this conjecture actually holds. However, one can find such a pair of prime numbers, if any, for a given even number. The problem here is to write a program that reports the number of all the pairs of prime numbers satisfying the condition in the conjecture for a given even number.

A sequence of even numbers is given as input. Corresponding to each number, the program should output the number of pairs mentioned above. Notice that we are interested in the number of essentially different pairs and therefore you should not count (p1, p2) and (p2, p1) separately as two different pairs.
 

Input
An integer is given in each input line. You may assume that each integer is even, and is greater than or equal to 4 and less than 2^15. The end of the input is indicated by a number 0.
 

Output
Each output line should contain an integer number. No other characters should appear in the output.
 

Sample Input
  
  
6 10 12 0
 

Sample Output
  
  
1 2 1

题意:这道题就是著名的哥德巴赫猜想,一个偶数总会分解成两个素数的和,现在给出一个偶数,它是由两个素数相加得到,求出有多少对不同的素数。

打个素数表,遍历所有小于该偶数一半的数,计算满足条件的数有多少个。

#include<stdio.h>
#include<string.h>
#include<math.h>
bool p[100000];
int i,j;


bool prime(int n)
{
    int a=2;
    while (a<n)
        if (!(n%a++)) break;
    if (a==n)
        return 1;
    return 0;
}
void initPrime()
{
    memset(p,0,sizeof(p));
    int end=(int)pow(2.0,15);
    for(int i=1; i<=end; i++)
    {
        if(prime(i))
            p[i]=1;
    }
}


int main()
{
    int n,m,N;
    initPrime();
    while(~scanf("%d",&n)&&n)
    {
        N=n/2;
        int sum=0;
        for(i=2; i<=N; i++)
        {
            if(p[i]==1&&p[n-i]==1)
                sum++;
        }
        printf("%d\n",sum);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值