HDU 3072 Intelligence System 缩点之和在DAG图上求最少费用

点击打开链接

 

Intelligence System

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1079    Accepted Submission(s): 487


Problem Description
After a day, ALPCs finally complete their ultimate intelligence system, the purpose of it is of course for ACM ... ...
Now, kzc_tc, the head of the Intelligence Department (his code is once 48, but now 0), is sudden obtaining important information from one Intelligence personnel. That relates to the strategic direction and future development of the situation of ALPC. So it need for emergency notification to all Intelligence personnel, he decides to use the intelligence system (kzc_tc inform one, and the one inform other one or more, and so on. Finally the information is known to all).
We know this is a dangerous work. Each transmission of the information can only be made through a fixed approach, from a fixed person to another fixed, and cannot be exchanged, but between two persons may have more than one way for transferring. Each act of the transmission cost Ci (1 <= Ci <= 100000), the total cost of the transmission if inform some ones in our ALPC intelligence agency is their costs sum.
Something good, if two people can inform each other, directly or indirectly through someone else, then they belong to the same branch (kzc_tc is in one branch, too!). This case, it’s very easy to inform each other, so that the cost between persons in the same branch will be ignored. The number of branch in intelligence agency is no more than one hundred.
As a result of the current tensions of ALPC’s funds, kzc_tc now has all relationships in his Intelligence system, and he want to write a program to achieve the minimum cost to ensure that everyone knows this intelligence.
It's really annoying!
 


 

Input
There are several test cases.
In each case, the first line is an Integer N (0< N <= 50000), the number of the intelligence personnel including kzc_tc. Their code is numbered from 0 to N-1. And then M (0<= M <= 100000), the number of the transmission approach.
The next M lines, each line contains three integers, X, Y and C means person X transfer information to person Y cost C.
 


 

Output
The minimum total cost for inform everyone.
Believe kzc_tc’s working! There always is a way for him to communicate with all other intelligence personnel.
 


 

Sample Input
  
  
3 3 0 1 100 1 2 50 0 2 100 3 3 0 1 100 1 2 50 2 1 100 2 2 0 1 50 0 1 100
 


 

Sample Output
  
  
150 100 50
 


 

Source
 


 

Recommend
lcy
 

 

题意是说有一些情报人员可以互相传达消息,传达时有一个费用值。如果几个情报人员可以相互传达,那么它们之间就不需要花费。让你求所有的情报人员都能收到消息时的最小费用。

强连通缩点,然后得到一个DAG图,在求每个点入度最小的费用值即可。

 

#include<stdio.h>
#include<string.h>
#define min(a,b) (a<b?a:b)
#define max(a,b) (a>b?a:b)
#define inf 0x3f3f3f
#define M 50017
bool vis[M];
int head[M],low[M],dfn[M],indegree[M],outdegree[M];
int stack[M],belong[M],count1[M];
int n,m,cnt,top,count,num;

struct node
{
    int s,e,cost,pre;
}g[M*2];


void insert(int a,int b,int c)
{
    g[num].s=a;
    g[num].e=b;
    g[num].cost=c;
    g[num].pre=head[a];
    head[a]=num++;
}

void init()
{
    cnt=top=count=num=0;
    memset(head,-1,sizeof(head));
    memset(vis,false,sizeof(vis));
    memset(dfn,0,sizeof(dfn));
    memset(indegree,0,sizeof(indegree));
    memset(outdegree,0,sizeof(outdegree));
}

void tarjan(int x)
{
    dfn[x]=low[x]=++cnt;
    stack[top++]=x;
    vis[x]=true;
    for(int i=head[x];i!=-1;i=g[i].pre)
    {
        int u=g[i].e;
        if(!dfn[u])
        {
            tarjan(u);
            low[x]=min(low[x],low[u]);
        }
        else if(vis[u])
        {
            low[x]=min(low[x],dfn[u]);
        }
    }
    if(low[x]==dfn[x])
    {
        count++;
        int tmp;
        while(1)
        {
            tmp=stack[--top];
            belong[tmp]=count;
            vis[tmp]=false;
            if(tmp==x)
                break;
        }
    }
}

void output()
{
    int inde=0,outde=0;
    for(int i=0;i<=n;i++)
        count1[i]=inf;
    for(int i=1;i<=n;i++)
    {
        int v=belong[i];
        for(int j=head[i];j!=-1;j=g[j].pre)
        {
            int u=belong[g[j].e];
            if(v!=u)//如果不在一个缩点里面
            {
                count1[u]=min(count1[u],g[j].cost);//找入度费用最小的那个
            }
        }
    }

    int ans=0;
    for(int i=1;i<=n;i++)
        if(count1[i]!=inf)//将入度为0的点去掉
            ans+=count1[i];
    printf("%d\n",ans);
}

int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        init();
        int a,b,c;
        for(int i=0;i<m;i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            insert(a+1,b+1,c);
        }
        for(int i=1;i<=n;i++)
            if(!dfn[i])
                tarjan(i);
        output();
    }
    return 0;
}


 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值