Equal Sum Partitions

                                                                                                                                            点击打开链接

 

                                                                                                            Problem A: Equal Sum Partitions

Equal Sum PartitionsTime Limit: 1 Sec  Memory Limit: 128 MB
Submit: 36  Solved: 27
[Submit][Status][Web Board]

Description

An equal sum partition of a sequence of numbers is a grouping of the numbers (in the same order

as the original sequence) in such a way that each group has the same sum.           For example, the

sequence:

2 5 1 3 3 7

may be grouped as:

(2 5) (1 3 3) (7)

to yield an equal sum of 7.

Note: The partition that puts all the numbers in a single group is an equal sum partition with the sum equal to the sum of all the numbers in the sequence.

For this problem, you will write a program that takes as input a sequence of positive integers and

returns the smallest sum for an equal sum partition of the sequence.

Input

The first line of input contains a single integer P, (1 P 1000), which is the number of data sets that

follow. The first line of each data set contains the data set number, followed by a space, followed by

a decimal integer M, (1 M 10000), giving the total number of integers in the sequence.          The

remaining line(s) in the dataset consist of the values, 10 per line, separated by a single space.       The last line in the dataset may contain less than 10 values.

Output

For each data set, generate one line of output with the following values:   The data set number as a decimal integer, a space, and the smallest sum for an equal sum partition of the sequence.

Sample Input

3
1 6
2 5 1 3 3 7
2 6
1 2 3 4 5 6
3 20
1 1 2 1 1 2 1 1 2 1
1 2 1 1 2 1 1 2 1 1

Sample Output

1 7
2 21
3 2

 

 

dp题目真费脑子啊。哭

#include<stdio.h>
#include<string.h>
int s[1007],dp[1007][1007];
int main()
{
    int t,i,j,k;
    scanf("%d",&t);
    for(int textcase=1; textcase<=t; textcase++)
    {
        memset(dp,0,sizeof(dp));
        int n,m,sum,flag,flag1=0,max;
        scanf("%d%d",&n,&m);
        for(i=1; i<=m; i++)
        {
            scanf("%d",&s[i]);
        }
        for(j=1; j<=m; j++)
        {
            dp[1][j]=s[j]+dp[1][j-1];
            max=dp[1][j];
            flag=j;
            //printf("\n");
            for(k=flag+1; k<=m; k++)
            {
                dp[flag+1][k]=s[k]+dp[flag+1][k-1];
                //printf("%d\n",dp[flag+1][k]);

                if(k==m)
                {
                    if(dp[flag+1][m]!=max)
                        break;
                    else
                    {
                        flag1=1;
                        break;
                    }
                }
                if(dp[flag+1][k]==max)
                {
                    flag=k;
                }
            }
            if(flag1==1)
                break;
        }
        printf("%d %d\n",textcase,max);
    }

    return 0;
}


 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值