ZOJ 2480 Simplest Task in Windows


Simplest Task in Windows

Time Limit: 2 Seconds       Memory Limit: 65536 KB

A typical windows platform may have several windows on the desktop. A user's operation may be as simple as a single click of the mouse. In the implementation of such a windows platform, one of the simplest tasks would be deciding which window had been clicked.

Given a serial of windows, for each mouse click, decide which window had been clicked. Please notice that windows may overlap, and the window on top would receive the click rather than others. And, we consider a window to be clicked even if the mouse is just on its edge/corner. For the sake of simplicity, we assume that a window will not be activated to the top by any click.


Input

The first part of input is a serial of windows. First an integer N (1 <= N <= 10) is given, indicating the number of windows. Then N lines follow, each containing four integers, x1, y1, x2, y2, (x1 < x2, y1 < y2) the coordinates of the upper-left and lower-right corners of a window. The windows are given in back-to-front order. N=0 signals the end of input.

The second part of input is a serial of mouse clicks. First an integer M (1 <= M <= 50) is given, indicating the number of mouse clicks. Then M lines follow, each containing two integers, x and y, the coordinates of a mouse click.


Output

For each mouse click in the input, output a single line containing the index (starting from 0) of the window which receives the click. If there is no such window, output "-1" in a line instead.


Sample Input

1
0 0 5 5
3
4 1
5 1
6 1
0


Sample Output

0
0
-1



Author:  SHI, Xiaohan
Source:  Zhejiang Provincial Programming Contest 2005

题意是说有电脑屏幕上有n个窗口,编号分别为0到n-1,给你每个窗口的左上角坐标和右下角坐标,可能有的窗口会覆盖,窗口时从后往前给的,然后给你m个坐标,让你判读这个坐标点击在第几个窗口上,如果覆盖则输出最前面的窗口编号,如果没有点击在窗口上,则输出-1.
#include<stdio.h>
#include<string.h>
int dp[107][107];
int main()
{
    int n;
    while(scanf("%d",&n),n)
    {
        int a,b,c,d,m;
        memset(dp,-1,sizeof(dp));
        for(int i=0;i<n;i++)
        {
            scanf("%d%d%d%d",&a,&b,&c,&d);
            for(int j=a;j<=c;j++)
                for(int k=b;k<=d;k++)
                    dp[j][k]=i;
        }
        scanf("%d",&m);
        while(m--)
        {
            scanf("%d%d",&a,&b);
            printf("%d\n",dp[a][b]);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值