POJ1700--Crossing River(贪心)

26 篇文章 0 订阅

Do more with less

Description

A group of N people wishes to go across a river with only one boat, which can at most carry two persons. Therefore some sort of shuttle arrangement must be arranged in order to row the boat back and forth so that all people may cross. Each person has a different rowing speed; the speed of a couple is determined by the speed of the slower one. Your job is to determine a strategy that minimizes the time for these people to get across.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. The first line of each case contains N, and the second line contains N integers giving the time for each people to cross the river. Each case is preceded by a blank line. There won’t be more than 1000 people and nobody takes more than 100 seconds to cross.

Output

For each test case, print a line containing the total number of seconds required for all the N people to cross the river.

Sample Input

1
4
1 2 5 10

Sample Output

17

思路

先对数组进行排序 贪心的策略为 :
f(1)=a[1] 一个人过河
f(2)=a[2] 两个人过河
f(3)=a[2] 三个人过河
所以当 n <= 3 时 可以直接输出
当 n > 3 时 策略为①最快和次快过去,最快回;最慢和次慢过去,次快回,t=s[1]+s[0]+s[n-1]+s[1]。②最快和最慢过去,最快回;最快和次快过去,最快回,t=s[n-1]+s[0]+s[n-2]+s[0]。选择两者中用时较少的一个策略执行。如此便将最慢和次慢送过河,对剩下n-2个人循环处理。

代码

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int A[1005];
int n,time;
int eat(int m)
{
    if(m==1 )
    {
        return A[0];
    }
    if(m==2)
    {
        return A[1];
    }
    if(m==3)
    {
        return A[0]+A[1]+A[2];
    }
    int sum=0;
     sum = min(sum+A[1]+A[0]+A[m-1]+A[1],sum+A[m-2]+A[0]+A[m-1]+A[0]);

    return sum + eat(m-2);
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        memset(A,0,sizeof(A));
        time = 0;
        scanf("%d",&n);
        for(int i = 0;i < n;i ++)
        {
            scanf("%d",&A[i]);
        }
        sort(A,A+n);
        time = eat(n);
        printf("%d",time);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值