渡河问题(Crossing River)-贪心策略

Crossing River

group of N people wishes to go across a river with only one boat, which can at most carry two persons. Therefore some sort of shuttle arrangement must be arranged in order to row the boat back and forth so that all people may cross. Each person has a different rowing speed; the speed of a couple is determined by the speed of the slower one. Your job is to determine a strategy that minimizes the time for these people to get across.

Input
The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. The first line of each case contains N, and the second line contains N integers giving the time for each people to cross the river. Each case is preceded by a blank line. There won’t be more than 1000 people and nobody takes more than 100 seconds to cross.

Output
For each test case, print a line containing the total number of seconds required for all the N people to cross the river.

Sample Input
1
4
1 2 5 10

Sample Output
17


import java.util.Arrays;
import java.util.Scanner;

public class Main {
    public static void greedy(int N, int [] speeds){
        int left = N ; //还未渡河的人数
        int times = 0 ; //初始化渡河所需的总时间
        while(left > 0){
            if(left == 1){
                times += speeds[0] ;
                break ;
            }else if(left == 2){
                times += speeds[1] ;
                break ;
            }else if(left == 3){
                times += speeds[0] + speeds[1] + speeds[2] ;
                break ;
            }else{//两种渡河策略
                //快慢分组法:1,2渡河,1回来,3,4渡河,2回来
                int s1 = speeds[1] + speeds[0] + speeds[left-1] + speeds[1] ;
                //快带慢法:1,4渡河,1回来,1,3渡河,1回来
                int s2 = speeds[left-1] + speeds[left-2] + 2 * speeds[0] ;
                times += Math.min(s1, s2) ;
                left -= 2 ; //所需渡河人数减少2
            }
        }
        System.out.println(times) ;
    }
    public static void main(String[] args){
        Scanner input = new Scanner(System.in) ;
        int T = input.nextInt() ;
        for(int i=0; i<T; i++){
            int N = input.nextInt() ;
            int [] speeds = new int [N] ;
            for(int j=0; j<N; j++){
                speeds[j] = input.nextInt() ;
            }
            Arrays.sort(speeds) ;
            greedy(N, speeds) ;
        }

    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

nuist__NJUPT

给个鼓励吧,谢谢你

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值