Crossing River(贪心+模拟)

Crossing River
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Description

A group of N people wishes to go across a river with only one boat, which can at most carry two persons. Therefore some sort of shuttle arrangement must be arranged in order to row the boat back and forth so that all people may cross. Each person has a different rowing speed; the speed of a couple is determined by the speed of the slower one. Your job is to determine a strategy that minimizes the time for these people to get across.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. The first line of each case contains N, and the second line contains N integers giving the time for each people to cross the river. Each case is preceded by a blank line. There won't be more than 1000 people and nobody takes more than 100 seconds to cross.

Output

For each test case, print a line containing the total number of seconds required for all the N people to cross the river.

Sample Input

1
4
1 2 5 10

Sample Output

17


如果有N个人(N>=1)
如果N=1或N=2;所有人直接过河。
如果N=3;由最快的人往返一次把其他两人送过河。
如果N>=4;设A,B为走的最快的和次快的人,过桥时间为a,b;
设Z,Y是走的最慢和次慢的人,过桥时间为z,y:
当2b>a+y时,使用模式一将Z,Y送过桥
当2b<a+y时,使用模式二将Z,Y送过桥
当2b=a+y时,使用模式一或模式二将Z,Y送过桥
问题变回n-2个人,递归解决。
模式一:A将Z送过桥,然后返回,再把Y送过桥,再返回。
模式二:A,B先过桥,然后A返回,Y和Z过桥,然后B返回。


//过河问题
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[1005];
int main()
{
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);

        sort(a,a+n);

        if(n<=2)
        {
             printf("%d\n",a[n-1]);
             continue;
        }

        int sum=a[1];//最后一定是 a[0]。a[1]回去

        while(n>3)
        {
            if(a[0]+a[n-1]+a[0]+a[n-2]>=a[0]+a[1]+a[n-1]+a[1])
                sum+=a[0]+a[1]+a[n-1]+a[1];
            else
                sum+=a[0]+a[n-1]+a[0]+a[n-2];
            n-=2;
        }
        if(n==3)
            sum+=(a[0]+a[2]);
        printf("%d\n",sum);
    }
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值