XYZZY(SPFA变形:判断在有正负环的情况下如何找出最长路)

171 篇文章 0 订阅
99 篇文章 0 订阅


Link:http://acm.hdu.edu.cn/showproblem.php?pid=1317


XYZZY

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3435    Accepted Submission(s): 951


Problem Description
It has recently been discovered how to run open-source software on the Y-Crate gaming device. A number of enterprising designers have developed Advent-style games for deployment on the Y-Crate. Your job is to test a number of these designs to see which are winnable. 
Each game consists of a set of up to 100 rooms. One of the rooms is the start and one of the rooms is the finish. Each room has an energy value between -100 and +100. One-way doorways interconnect pairs of rooms. 

The player begins in the start room with 100 energy points. She may pass through any doorway that connects the room she is in to another room, thus entering the other room. The energy value of this room is added to the player's energy. This process continues until she wins by entering the finish room or dies by running out of energy (or quits in frustration). During her adventure the player may enter the same room several times, receiving its energy each time. 
 

Input
The input consists of several test cases. Each test case begins with n, the number of rooms. The rooms are numbered from 1 (the start room) to n (the finish room). Input for the n rooms follows. The input for each room consists of one or more lines containing: 

the energy value for room i 
the number of doorways leaving room i 
a list of the rooms that are reachable by the doorways leaving room i 
The start and finish rooms will always have enery level 0. A line containing -1 follows the last test case. 
 

Output
In one line for each case, output "winnable" if it is possible for the player to win, otherwise output "hopeless". 
 

Sample Input
  
  
5 0 1 2 -60 1 3 -60 1 4 20 1 5 0 0 5 0 1 2 20 1 3 -60 1 4 -60 1 5 0 0 5 0 1 2 21 1 3 -60 1 4 -60 1 5 0 0 5 0 1 2 20 2 1 3 -60 1 4 -60 1 5 0 0 -1
 

Sample Output
  
  
hopeless hopeless winnable winnable
 

Source
 


以下题意分析和思路参考博客:http://m.blog.csdn.net/blog/u013081425/26131645


题意分析:有n个房间,每个房间都有对应的能量值(可正可负),现在从1出发要到达n,初始能量为100,问是否能够达到n点,到达n的条件是中间及最后的能量值都要大于0。


思路:若不考虑环,那么求最长路判断是否大于0即可。若存在负环,对求最长路也没影响;但当存在正环时,最长路就不存在了。可用spfa判断,当某点入队超过n次,那么它必定在环中,直接将其dis置为INF,并不再将其进队列。最后若能到达n则可行,否则失败。


AC code:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<queue>
#include<vector>
#include<cmath>
#include<cstdio>
#include<map>
#define LL long long
using namespace std;
const int INF = 0x3f3f3f3f;
const int MAXN=1000010;
int n,tot;
int head[MAXN];
int cnt[MAXN];
bool vis[MAXN];
int power[MAXN];
int dis[MAXN];//这里表示的是最大的能量 
struct node{
	int to;
	int w;
	int next;
}edge[MAXN];
void init()
{
	memset(head,-1,sizeof(head));
	tot=0;
}
void add(int u,int v,int w)
{
	edge[tot].to=v;
	edge[tot].w=w;
	edge[tot].next=head[u];
	head[u]=tot++;
}
bool spfa()
{
	deque<int>q;
	for(int i=1;i<=n;i++)
	{
		dis[i]=-INF;
		vis[i]=false;
		cnt[i]=0;
	}
//	memset(dis,-INF,sizeof(dis));
//	memset(vis,false,sizeof(vis));
//	memset(cnt,0,sizeof(cnt));
	dis[1]=100;
	q.push_back(1);
	vis[1]=true;
	cnt[1]++;
	while(!q.empty())
	{
		int now=q.front();
		q.pop_front();
		vis[now]=false;
		if(cnt[now]>n)//在环中不再进队列
		{
			continue;
		}
		if(cnt[now]==n) //成环 
		{
			dis[now]=INF;//将dis置为INF,使其不再入队列 
		}
		for(int i=head[now];i!=-1;i=edge[i].next)
		{
			int nex=edge[i].to;
			if(dis[nex]<dis[now]+power[nex]&&dis[now]+power[nex]>0)
			{
				dis[nex]=dis[now]+power[nex];
				//if(nex==n)//能够到达n返回true
				//	return true; 
				if(!vis[nex])
				{
					vis[nex]=true;
					cnt[nex]++;
					if(!q.empty()&&dis[nex]>dis[q.front()])
					{
						q.push_front(nex);
					}
					else
					{
						 q.push_back(nex);
					}
				}
			}
		}
	}
	return false;
}
int main()
{
	//freopen("D:\in.txt","r",stdin);
	int i,j,v,m;
	while(scanf("%d",&n)!=EOF)
	{
		if(n==-1)
			break;
		init();
		for(i=1;i<=n;i++)
		{
			scanf("%d",&power[i]);
			scanf("%d",&m);
			while(m--)
			{
				scanf("%d",&v);
				add(i,v,0);//有向图 
				//add(v,i,0);
			}
		}
		spfa();
		//if(spfa())//也可以通过这个来判断输出 
	    if(dis[n]>0)
		{
			printf("winnable\n");
		}
		else
		{
			printf("hopeless\n");
		}
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

林下的码路

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值