hdu1394 Minimum Inversion Number 最小逆序数 线段树单点更新区间查询

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16198    Accepted Submission(s): 9852


Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
  
  
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output
  
  
16
 

Author
CHEN, Gaoli



#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#define lson l, m, rt << 1
#define rson m + 1, r, rt << 1 | 1

using namespace std;

const int maxn = 5555;

int sum[maxn << 2];
int a[5555];

void PushUp(int rt) {
	sum[rt] = sum[rt << 1] + sum[rt << 1 | 1];
}

void build(int l, int r, int rt) {
	if (l == r) {
		sum[rt] = 0;
		return;
	}
	int m = (l + r) >> 1;
	build(lson);
	build(rson);
	PushUp(rt);
}

int query(int L, int R, int l, int r, int rt) {
	if (L <= l && r <= R) {
		return sum[rt];
	}
	int m = (l + r) >> 1;
	if (R <= m)
		return query(L, R, lson);
	else if (L > m)
		return query(L, R, rson);
	else if (L <= m && R > m)
		return query(L, m, lson) + query(m + 1, R, rson);
}

//等价query另类写法

/*
int query(int L, int R, int l, int r, int rt) {
	if (L <= l && r <= R) {
		return sum[rt];
	}
	int m = (l + r) >> 1;
	int res = 0;
	if (L <= m) res += query(L, R, lson);
	if (R > m) res += query(L, R, rson);
		return res;
	}
*/


void update(int p, int l, int r, int rt) {
	if (l == r) {
		sum[rt]++;
		return;
	}
	int m = (l + r) >> 1;
	if (p <= m)
		update(p, lson);
	else
		update(p, rson);
	PushUp(rt);
}

int main()
{
	int N;
	while (~scanf("%d", &N)) {
		build(0, N - 1, 1);
		int ans = 0;
		for (int i = 0; i < N; i++) {
			scanf("%d", &a[i]);
			//查询>a[i]的之前输过的数有几个,就是这个数的逆序数
			ans += query(a[i], N - 1, 0, N - 1, 1);
			//将这个数记录下来,供后面的数计算逆序数
			update(a[i], 0, N - 1, 1);
		}
		int minn = ans;
		/*将a[i]移到最后面
		会减少a[i]个逆序,增加N - 1 - a[i]个逆序
		例如:
		3 6 9 0 8 5 7 4 2 1
		-->6 9 0 8 5 7 4 2 1 3
		原因是3使得0 1 2的逆序共减少了3,但是由于4 5 6 7 8 9使自己的逆序增加了10 - 1 - 3 = 6
		*/
		for (int i = 0; i < N - 1; i++) {
			ans += (N - 1 - a[i] - a[i]);
			minn = min(ans, minn);
		}
		printf("%d\n", minn);
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值