poj3468 A Simple Problem with Integers 线段树延迟标记区间更新区间求和

A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 86916 Accepted: 26983
Case Time Limit: 2000MS

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.


模板题,线段树区间更新,区间求和,用延迟标记,注意long long和PushDown的方式就好


#include <cstdio>
#include <cstring>
#include <iostream>
#define lson l, m, rt << 1
#define rson m + 1, r, rt << 1 | 1

using namespace std;

const int maxn = 111111;
long long sum[maxn << 2];
long long col[maxn << 2];

void PushUp(int rt) {
	sum[rt] = sum[rt << 1] + sum[rt << 1 | 1];
}

void PushDown(int rt, int m) {
	if (col[rt]) {
		col[rt << 1] += col[rt];
		col[rt << 1 | 1] += col[rt];
		sum[rt << 1] += (m - (m >> 1)) * col[rt];  //注意是乘以col[rt]不是col[rt << 1]
		sum[rt << 1 | 1] += (m >> 1) * col[rt];  //注意是乘以col[rt]不是col[rt << 1 | 1]
		col[rt] = 0;
	}
}

void build(int l, int r, int rt) {
	sum[rt] = 0;
	col[rt] = 0;
	if (l == r) {
		scanf("%I64d", &sum[rt]);
		getchar(); //缓冲
		return;
	}
	int m = (l + r) >> 1;
	build(lson);
	build(rson);
	PushUp(rt);
}

long long query(int L, int R, int l, int r, int rt) {		
	if (L <= l && r <= R) {
		return sum[rt];
	}
	PushDown(rt, r - l + 1);
	int m = (l + r) >> 1;
	long long res = 0;
	if (L <= m) res += query(L, R, lson);
	if (R > m) res += query(L, R, rson);
	return res;
}

void update(int L, int R, int c, int l, int r, int rt) {
	if (L <= l && r <= R) {
		col[rt] += c;
		sum[rt] += (r - l + 1) * c; //注意是乘以c不是乘以col[rt]
		return;
	}
	PushDown(rt, r - l + 1);
	int m = (l + r) >> 1;
	if (L <= m) update(L, R, c, lson);
	if (R > m) update(L, R, c, rson);

	PushUp(rt);
}

int main()
{
	int N, Q;
	cin >> N >> Q;
	build(1, N, 1);
	char ch;
	int a, b, c;
	for (int i = 1; i <= Q; i++) {
		scanf("%c %d %d", &ch, &a, &b);
		getchar(); //缓冲
		if (ch == 'Q') {
			printf("%I64d\n", query(a, b, 1, N, 1));
		}
		else if (ch == 'C') {
			scanf("%d", &c);
			getchar(); //缓冲
			update(a, b, c, 1, N, 1);
		}
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值