关闭

关于 AnnotationConfigBeanDefinitionParser are only available on JDK 1.5 and higher

标签: springannotation
2974人阅读 评论(1) 收藏 举报
分类:

使用注解的时候出现了如下问题:org.springframework.beans.factory.BeanDefinitionStoreException: Unexpected exception parsing XML document from class path resource [beans.xml]; nested exception is java.lang.IllegalStateException: Context namespace element 'annotation-config' and its parser class [org.springframework.context.annotation.AnnotationConfigBeanDefinitionParser are only available on JDK 1.5 and higher,

大意是说SPRING的注解配置解析器只能在JDK1.5或更高版本使用,可是我的ECLIPSE 默认的是1.8,我使用的SPRING版本是2.5,查过之后发现者应该是SPRING的一个BUG,可能新版本有修复吧,总而言之就是1.8的JDK太高了,SPRING 支持不了,修改方法也很简单,右键项目--》BUILD PATH--》Config Build Path--》Libraries-->Jre System Library--》Edit--》然后选择后面小括号里面标注为1.6的就OK 啦!

1
1

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:30625次
    • 积分:570
    • 等级:
    • 排名:千里之外
    • 原创:24篇
    • 转载:21篇
    • 译文:0篇
    • 评论:13条
    文章分类
    最新评论