关于 AnnotationConfigBeanDefinitionParser are only available on JDK 1.5 and higher

使用注解的时候出现了如下问题:org.springframework.beans.factory.BeanDefinitionStoreException: Unexpected exception parsing XML document from class path resource [beans.xml]; nested exception is java.lang.IllegalStateException: Context namespace element 'annotation-config' and its parser class [org.springframework.context.annotation.AnnotationConfigBeanDefinitionParser are only available on JDK 1.5 and higher,

大意是说SPRING的注解配置解析器只能在JDK1.5或更高版本使用,可是我的ECLIPSE 默认的是1.8,我使用的SPRING版本是2.5,查过之后发现者应该是SPRING的一个BUG,可能新版本有修复吧,总而言之就是1.8的JDK太高了,SPRING 支持不了,修改方法也很简单,右键项目--》BUILD PATH--》Config Build Path--》Libraries-->Jre System Library--》Edit--》然后选择后面小括号里面标注为1.6的就OK 啦!

阅读更多
文章标签: spring annotation
个人分类: Java
上一篇jsp界面中不识别EL表达式
下一篇从高版本JDK换成低版本JDK报错Unsupported major.minor version 52.0
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

关闭
关闭